summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorlevinit2018-05-25 14:59:33 +0800
committerlevinit2018-05-25 14:59:33 +0800
commit20dca482bc8a42f29ab757fc26bae498f842a0ec (patch)
tree8a0a9123a87ae288a43563a5d5050ce1f5e42880 /PKGBUILD
downloadaur-20dca482bc8a42f29ab757fc26bae498f842a0ec.tar.gz
1.4beta
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f19a0fa660d5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: levinit <levinit at outlook>
+
+pkgname=iceworks
+pkgver=1.4.0
+pkgrel=1
+pkgdesc="icework make front-end engineering becomes easy and convenient.飞冰,让前端工程变得轻松便捷。"
+arch=('x86_64')
+url="https://mockingbot.com/downloads"
+license=('MIT')
+depends=()
+
+source=("https://iceworks-beta.oss-cn-hangzhou.aliyuncs.com/linux/Iceworks-amd64-1.4.0-beta.deb")
+md5sums=('SKIP')
+
+package() {
+ tar -xvf data.tar.xz -C ${pkgdir}
+
+ #edit app's desktop file
+ sed -i '/Comment/d' ${pkgdir}/usr/share/applications/iceworks-desktop.desktop
+ echo -e '
+Name[zh_CN]=飞冰
+Name[zh_TW]=飛冰
+Name[zh_HK]=飛冰
+Comment=icework make front-end engineering becomes easy and convenient
+Comment[zh_CN]=飞冰 让前端工程变得轻松便捷
+Comment[zh_TW]=飛冰 讓前端工程變得輕鬆便捷
+Comment[zh_HK]=飛冰 讓前端工程變得輕鬆便捷' >> ${pkgdir}/usr/share/applications/iceworks-desktop.desktop
+
+ chmod -R go-w "${pkgdir}"/usr
+ install -dm755 "${pkgdir}/usr/bin"
+}