summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJulian Brost2021-07-13 21:40:24 +0200
committerJulian Brost2021-07-13 21:40:24 +0200
commitde3fb7af58afb2c78387296f536600fa708ea0cb (patch)
tree8dd0f14aaa932091ed28c6d85581907d7bb8bb43 /PKGBUILD
downloadaur-de3fb7af58afb2c78387296f536600fa708ea0cb.tar.gz
new version 0.10.0-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 19 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a93ace5510b7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Julian Brost <julian@0x4a42.net>
+
+pkgname=icinga-php-thirdparty
+pkgver=0.10.0
+pkgrel=1
+pkgdesc="Bundle for all Icinga PHP libraries"
+arch=(any)
+url="https://github.com/Icinga/icinga-php-thirdparty"
+license=('MIT')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/Icinga/icinga-php-thirdparty/archive/refs/tags/v$pkgver.tar.gz")
+sha256sums=('40dfdc42dfc94f4c39a511b2dbadc8eb083d3362de27c216d8cb9aa48d812566')
+
+package() {
+ cd "$pkgname-$pkgver"
+
+ install -dm755 "$pkgdir/usr/share/icinga-php"
+ cp -rT . "$pkgdir/usr/share/icinga-php/vendor"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}