summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJulian Brost2019-10-08 19:38:20 +0200
committerJulian Brost2019-10-08 19:38:20 +0200
commit90393aa7410f9b7644f2dda245284fb85eeab943 (patch)
tree049d6f150118b7e2a7b0776b083167eabf83ab33 /PKGBUILD
parentf68063a9608410b621d7a75623ed4365182d5662 (diff)
downloadaur-90393aa7410f9b7644f2dda245284fb85eeab943.tar.gz
add workaround for boost version not being detected correctly
There is a problem with CMake>=3.15 and Boost>=1.70.0 where the value of a variable containing the boost version changed, for more details see https://github.com/Icinga/icinga2/issues/7566
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 9 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8be947830fcd..8411428b4378 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname='icinga2'
pkgver=2.11.0
-pkgrel=1
+pkgrel=2
pkgdesc="An open source host, service and network monitoring program"
license=('GPL')
arch=('i686' 'x86_64')
@@ -53,6 +53,9 @@ build() {
mkdir -p "$srcdir/$pkgname-$pkgver/build"
cd "$srcdir/$pkgname-$pkgver/build"
+ # The four lines settings variables regarding boost are a workaround for the
+ # boost version not being detected properly, see also
+ # https://github.com/Icinga/icinga2/issues/7566
cmake "$srcdir/$pkgname-$pkgver" \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_SYSCONFDIR=/etc \
@@ -63,7 +66,11 @@ build() {
-DICINGA2_SYSCONFIGFILE=/etc/default/icinga2 \
-DICINGA2_PLUGINDIR=/usr/lib/monitoring-plugins \
-DUSE_SYSTEMD=ON \
- -DLOGROTATE_HAS_SU=OFF
+ -DLOGROTATE_HAS_SU=OFF \
+ -DBoost_NO_BOOST_CMAKE=TRUE \
+ -DBoost_NO_SYSTEM_PATHS=TRUE \
+ -DBOOST_LIBRARYDIR=/usr/lib \
+ -DBOOST_INCLUDEDIR=/usr/include
make
}