summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMario Finelli2016-03-11 11:53:59 +0000
committerMario Finelli2016-03-11 11:53:59 +0000
commit3cf607fe4804a221c58fe5e17e329730131b54ea (patch)
tree78de30b99c7e7e36aeb4b76a8b18fb9c79a93466 /PKGBUILD
parent0cc6e351516bf823a34d6128fad15777d4f7eb70 (diff)
downloadaur-3cf607fe4804a221c58fe5e17e329730131b54ea.tar.gz
Clean up PKGBUILD
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 10 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f1b2dfccc09d..3b8fc963bc10 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=icmptunnel-git
pkgver=r58.7a1a5a8
-pkgrel=2
+pkgrel=3
pkgdesc="Transparently tunnel your IP traffic through ICMP echo and reply packets."
arch=('i686' 'x86_64')
url="https://github.com/DhavalKapil/icmptunnel"
@@ -15,8 +15,9 @@ source=('git://github.com/DhavalKapil/icmptunnel.git')
md5sums=('SKIP')
pkgver() {
- cd "$srcdir/icmptunnel"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ cd "$srcdir/icmptunnel"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" \
+ "$(git rev-parse --short HEAD)"
}
prepare() {
@@ -26,14 +27,14 @@ prepare() {
}
build(){
- cd "$srcdir/icmptunnel"
- make
+ cd "$srcdir/icmptunnel"
+ make
}
package(){
- cd "$srcdir/icmptunnel"
- install -Dm0755 icmptunnel "$pkgdir"/usr/bin/icmptunnel
+ cd "$srcdir/icmptunnel"
+ install -Dm0755 icmptunnel "$pkgdir"/usr/bin/icmptunnel
- install -Dm0755 client.sh "$pkgdir"/usr/bin/icmptunnel-client
- install -Dm0755 server.sh "$pkgdir"/usr/bin/icmptunnel-server
+ install -Dm0755 client.sh "$pkgdir"/usr/bin/icmptunnel-client
+ install -Dm0755 server.sh "$pkgdir"/usr/bin/icmptunnel-server
}