summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGianluca Boiano2021-02-07 11:19:24 +0100
committerGianluca Boiano2021-02-07 11:19:24 +0100
commitafa3177800f65d5907f6c2cc5725f8f8f5d6fc65 (patch)
treee5d1e6032028a8deeb088ac18b642f5aa8ddb0ae /PKGBUILD
parentafa54da478ac5ae15b16a7ebddf30c0a992bee6a (diff)
downloadaur-afa3177800f65d5907f6c2cc5725f8f8f5d6fc65.tar.gz
idjc: 0.9.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD62
1 files changed, 31 insertions, 31 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 990ffba017e6..23a7f8b6bf29 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,53 +4,53 @@
# Contributor: Gaetan Bisson <bisson@archlinux.org>
pkgname=idjc
-pkgver=0.8.17
-pkgrel=4
+pkgver=0.9.0
+pkgrel=1
pkgdesc='Powerful client for individuals interested in streaming live radio shows'
url='http://idjc.sourceforge.net/'
license=('GPL2')
arch=('i686' 'x86_64')
depends=(
- 'desktop-file-utils'
- 'ffmpeg'
- 'flac'
- 'glib2'
- 'jack'
- 'lame'
- 'libmad'
- 'libsamplerate'
- 'libshout-idjc'
- 'libsndfile'
- 'pygtk'
- 'python2'
- 'python2-dbus'
- 'python2-mutagen'
- 'speex'
- 'twolame'
- 'vorbis-tools'
+ 'desktop-file-utils'
+ 'ffmpeg'
+ 'flac'
+ 'glib2'
+ 'jack'
+ 'lame'
+ 'libmad'
+ 'libsamplerate'
+ 'libshout-idjc'
+ 'libsndfile'
+ 'python'
+ 'python-dbus'
+ 'python-gobject'
+ 'python-mutagen'
+ 'speex'
+ 'twolame'
+ 'vorbis-tools'
)
-
optdepends=('mysql-python: Ampache and Prokyon 3 support'
-'python2-irc3: IRC notification support')
+ 'python-irc: IRC notification support')
conflicts=('idjc-git')
-install=${pkgname}.install
source=("http://downloads.sourceforge.net/${pkgname}/${pkgname}-${pkgver}.tar.gz")
build() {
- cd "${srcdir}/${pkgname}-${pkgver}"
-
- export PYTHON=/usr/bin/python2
- ./configure \
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ ./configure \
--prefix=/usr \
--libexecdir=/usr/lib \
--disable-static
- make
+ make
}
package() {
- cd "${srcdir}/${pkgname}-${pkgver}"
- make DESTDIR="${pkgdir}" install
- sed -i "s/Icon=\/usr\/share\/pixmaps\/$pkgname.png/Icon=$pkgname/g" $pkgdir/usr/share/applications/$pkgname.desktop
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ make DESTDIR="${pkgdir}" install
+
+ sed -i "s/Icon=\/usr\/share\/pixmaps\/${pkgname}.png/Icon=${pkgname}/g" \
+ ${pkgdir}/usr/share/applications/${pkgname}.desktop
}
-md5sums=('47f13035d94f5c378bf237c335194a4d')
+md5sums=('dda1dad6a2b39b6b7366249300ecb3b2')