summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorroot2021-07-04 16:10:20 +0200
committerroot2021-07-04 16:10:20 +0200
commitac63d6eeba925f8b28a030d200f9d0fdc259ecde (patch)
treed1daffaf231f8d1f5986718b8727497f6f9e5762 /PKGBUILD
downloadaur-ac63d6eeba925f8b28a030d200f9d0fdc259ecde.tar.gz
Initial Commit.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD44
1 files changed, 44 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..31cfdb06d928
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: dreieck
+
+# PKGBUILD last time manually edited: At least on 2021-07-04.
+
+_year='21'
+
+_fullyear="20${_year}"
+
+_pkgname="idos-timetable-data-chaps-trains-cz"
+pkgname="${_pkgname}"
+epoch=0
+pkgver="${_fullyear}"
+pkgrel=1
+pkgdesc="Metapackage designed to depend on the latest ${_pkgname} data package."
+arch=(any)
+url="http://chaps.cz/eng/download/idos/zip#kotvatt"
+# url="http://chaps.cz/eng/download/idos-new/zip#kotvatt" # URL valid for the time when the timetable is still in the future.
+license=('custom: public domain')
+
+groups=(
+ "idos-timetable"
+ )
+
+depends=(
+ "${_pkgname}-${_fullyear}"
+ )
+
+makedepends=()
+optdepends=()
+provides=()
+replaces=()
+conflicts=()
+
+source=(
+ "license-metapackage-pd.txt"
+)
+
+sha256sums=(
+ "1e86f8ac1ad7315c76f4db8bf6a1dbdde6825ac95ff468e431bbe452b6865ae6"
+)
+
+package() {
+ install -D -m644 "${srcdir}/license-metapackage-pd.txt" "${pkgdir}/usr/share/licenses/${pkgname}/copying.txt"
+}