summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorfelics2018-12-10 15:40:09 +0100
committerfelics2018-12-10 15:40:09 +0100
commitffd9f0b4d8ef45fbbc480a6d76c0732fca336447 (patch)
treec730daa63741733746bca6cf99dead0b58763361 /PKGBUILD
downloadaur-ffd9f0b4d8ef45fbbc480a6d76c0732fca336447.tar.gz
Initial Commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD97
1 files changed, 97 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..728a2fed4b41
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,97 @@
+# Maintainer: dreieck
+
+# PKGBUILD last time manually edited: At least on 2018-12-10.
+
+_year='19'
+_prevyear="$(( ${_year} - 1 ))"
+
+_pkgname="idos-timetable-data-chaps-trains-odis-20${_year}"
+pkgname="${_pkgname}-latest"
+epoch=0
+pkgver=2018_11_29
+pkgrel=1
+pkgdesc="20${_prevyear}/20${_year} Timetable data for the timetable search engines by CHAPS: Trains in Ostrava public transport reagion (ODIS). Note that this timetable needs the purchased version of IDOS to run."
+arch=(any)
+url="http://chaps.cz/eng/download/idos/zip#kotvatt"
+license=('custom')
+
+groups=(
+ "idos-timetable"
+ )
+
+depends=(
+ "idos-timetable-data-trains-common"
+ )
+
+makedepends=(
+ "wget"
+)
+
+optdepends=(
+ "idos-timetable-tariff-mhd-odis: For showing prices."
+ "idos-timetable-maps-mhd-odis: For displaying routes on maps."
+ "idos-timetable-additionalinfo-mhd-odis: For additional information (changes, fare, sales points, etc.)."
+ "idos-timetable-browser-license: To use this timetable."
+ )
+
+provides=(
+ "${_pkgname}=${pkgver}"
+
+ "idos-timetable-data=${pkgver}"
+ "idos-timetable-data-trains=${pkgver}"
+
+ "idos-timetable-data-trains-odis=${pkgver}"
+ "idos-timetable-data-trains-odis-20${_year}=${pkgver}"
+)
+
+replaces=(
+ 'idos-timetable-data-chaps-trains-odis-latest'
+ "${_pkgname}<=${pkgver}"
+)
+
+conflicts=(
+ "${_pkgname}"
+ ### The conflict will be handled by idos-timetable-data-chaps-all, if needed. Sometimes idos-timetable-data-chaps-all does not provide the train data, and then idos-timetable-data-chaps-all will depend on this package, thus this package should not have idos-timetable-data-chaps-all as conflict.
+ # "idos-timetable-data-chaps-all"
+)
+
+_zipfile="VLAKODIS${_year}.ZIP"
+_target="vlakodis${_year}.zip"
+
+source=(
+ "${_target}::http://ttakt.chaps.cz/TTAktual/Win/Zip/${_zipfile}"
+ "IDOS-Licence.pdf::http://chaps.cz/files/idos/IDOS-Licence.pdf"
+ "license-dummy.txt"
+)
+
+sha256sums=(
+ 'SKIP'
+ "SKIP"
+ "c6bb216055d3670d3100b7a74e04ce0644030f365f4349a09e630ef60fbcb9a4"
+)
+
+pkgver() {
+ # Do not use metadata of the source file, but do website parsing: So we do not need to download the file to (AUR-)update the package version with our own crude hacked script 'idos-aur-update-versions.sh'.
+ #date -r "${srcdir}/${_target}" +"%Y_%m_%d"
+
+ wget -nv -O- "${url}" | tr -d '\a' | tr '\n' '\a' | sed 's|^.*File '"${_zipfile}"'\(.*\)Zip/'"${_zipfile}"'.*$|\1\n|g' | tr '\a' '\n' | grep 'Update date:' | cut -d, -f1 | sed -r 's|([0-9]+)\.([0-9]+)\.([0-9]+).|\n\3_\2_\1\n|g' | grep -E '^[0-9]+_[0-9]+_[0-9]+'
+}
+
+
+package() {
+ _instdirbase='/opt/idos-timetable'
+ _instdir="${pkgdir}/${_instdirbase}"
+ install -d -m755 "${_instdir}"
+
+ cp -r "${srcdir}"/Data* "${_instdir}/"
+ chmod 755 "${_instdir}"/Data*
+ chmod 644 "${_instdir}"/Data*/*
+ rm -f "${_instdir}/Data1"/[vV][lL][aA][kK].[tT][tT][rR] # This one is provided by idos-timetable-data-trains-common.
+
+ install -d -m755 "${pkgdir}/usr/share/doc/${_pkgname}"
+ echo "${url}" > "${pkgdir}/usr/share/doc/${_pkgname}/info.url"
+ chmod 644 "${pkgdir}/usr/share/doc/${_pkgname}/info.url"
+
+ install -D -m644 "${srcdir}/license-dummy.txt" "${pkgdir}/usr/share/licenses/${pkgname}/copying.txt"
+ install -D -m644 "${srcdir}/IDOS-Licence.pdf" "${pkgdir}/usr/share/licenses/${pkgname}/IDOS-Licence.pdf"
+}