summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorfelics@felics-tablet2017-12-17 21:15:56 +0100
committerfelics@felics-tablet2017-12-17 21:15:56 +0100
commite8648eee4a7d6c1b2e3eef54821b8675af02d7a5 (patch)
tree10a4d756a34afeff2b886a0791e6fca7fcd9e1ec /PKGBUILD
parent63ec5e84d041c144d16e9421da6908d970d1f278 (diff)
downloadaur-e8648eee4a7d6c1b2e3eef54821b8675af02d7a5.tar.gz
pkgver() updated.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 8 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 01749be8ccb2..39895b84d3ad 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@ _pkgname="idos-timetable-data-zsr-europe+sk-20${_year}"
pkgname="${_pkgname}-latest"
epoch=0
pkgver=2017_12_14
-pkgrel=1
+pkgrel=2
pkgdesc="20${_prevyear}/20${_year} Timetable data for the offline railway and other public transport timetable search engines by CHAPS: European and Slovak train data, provided by ŽSR."
arch=(any)
# url="http://www2.zsr.sk/pre-cestujucich/elis-vas-pocitac/instalacny-program-elis-k-cestovnemu-poriadku-cp-2017-2018.html"
@@ -77,13 +77,14 @@ sha256sums=(
)
pkgver() {
- date -r "${srcdir}/${_target0}" +"%Y_%m_%d"
+ # Do not use metadata of the source file, but do website parsing: So we do not need to download the file to (AUR-)update the package version with our own crude hacked script 'idos-aur-update-versions.sh'.
+ #date -r "${srcdir}/${_target0}" +"%Y_%m_%d"
- # _day="$(basename "${_source0}" .exe | cut -d- -f4)"
- # _month="$(basename "${_source0}" .exe | cut -d- -f3)"
- # _year="$(basename "${_source0}" .exe | cut -d- -f2)"
- #
- # echo "${_year}_${_month}_${_day}"
+ _day="$(basename "${_source0}" .exe | cut -d- -f4)"
+ _month="$(basename "${_source0}" .exe | cut -d- -f3)"
+ _year="$(basename "${_source0}" .exe | cut -d- -f2)"
+
+ echo "${_year}_${_month}_${_day}"
}