summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoryhfudev2015-08-30 23:29:57 -0400
committeryhfudev2015-08-30 23:29:57 -0400
commit7698a926b8f762e4eb1596e21dc564e0128b3653 (patch)
tree7d9cad2bdbf5860bafd7be4c1571962c62abd3cd /PKGBUILD
downloadaur-7698a926b8f762e4eb1596e21dc564e0128b3653.tar.gz
init
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9e97b8c284cd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Yunhui Fu <yhfudev@gmail.com>
+# Contributor: Ken Bull <llubnek@gmail.com>
+# Contributor: Todd Musall <tmusall@comcast.net>
+# Contributor: tardo <tardo@nagi-fanboi.net>
+
+pkgname=idutils
+pkgver=4.6
+pkgrel=1
+pkgdesc="A package of language independent tools that indexes program identifiers, literal numbers, \
+ or words of human-readable text."
+arch=('i686' 'x86_64')
+url="http://www.gnu.org/software/idutils/"
+license=('GPL')
+depends=('bash')
+replaces=('id-utils')
+source=(ftp://ftp.gnu.org/gnu/idutils/idutils-$pkgver.tar.xz)
+md5sums=('99b572536377fcddb4d38e86a3c215fd')
+
+build() {
+ cd $startdir/src/$pkgname-$pkgver
+ sed -i -e '/gets is a security/d' lib/stdio.in.h
+ ./configure --prefix=/usr --disable-gcc-warnings --disable-silent-rules
+ #export LC_CTYPE=ISO-8859-1
+ make VERBOSE=1 || return 1
+}
+
+package () {
+ cd $startdir/src/$pkgname-$pkgver
+ make DESTDIR=$startdir/pkg install
+ # why was this necessary?
+ #mkdir -p $startdir/pkg/usr/share/misc
+ #mv $startdir/pkg/usr/share/id-lang.map $startdir/pkg/usr/share/misc/
+}