summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSam Whited2020-05-09 18:58:40 -0400
committerSam Whited2020-05-09 18:58:40 -0400
commit58c0013b5ef2927f78ad62945192d2b0dec28dab (patch)
tree22c00a034ce01be926c65df62d5e5ad23f96782e /PKGBUILD
parent5d085ebc3f05f2cf5af16d5d2976ac843b0825f0 (diff)
downloadaur-58c0013b5ef2927f78ad62945192d2b0dec28dab.tar.gz
minor cleanup and remove requests from depends
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 7 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a5b11a5c6a82..ac7586607a51 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,25 @@
# Maintainer: Sam Whited <sam@samwhited.com>
-_pkgname=id2xml
pkgname=ietf-id2xml
+_name=${pkgname#ietf-}
pkgver=1.5.0
-pkgrel=2
+pkgrel=3
pkgdesc='Convert internet-draft text to XML'
url='https://pypi.org/project/id2xml/'
arch=(any)
+provides=("$_name")
+conflicts=("$_name")
depends=(python-decorator
python-lxml
python-pathlib2
- python-requests
python-six
xml2rfc)
-license=(custom:BSD)
-source=("https://files.pythonhosted.org/packages/source/${_pkgname::1}/$_pkgname/$_pkgname-$pkgver.tar.gz")
+license=(BSD)
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
sha256sums=('589c74051e0da91096b46af5d6ab33a616085a0551405b4e2fc254e3180c1107')
package() {
- cd "$srcdir/$_pkgname-$pkgver"
+ cd "$_name-$pkgver"
python setup.py install --root="$pkgdir"
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"