summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGökçe Aydos2023-09-26 04:55:02 +0200
committerGitHub2023-09-25 21:55:02 -0500
commit234705a3fe5f9b23082646f92cbbeae7b02da4d2 (patch)
treef8cd76c3321da0450a1df57211530e8e2f956d34 /PKGBUILD
parentfab43e4f6d532edaa7c1f95438813da3b5e02810 (diff)
downloadaur-234705a3fe5f9b23082646f92cbbeae7b02da4d2.tar.gz
update to 5.4, fix gcc13 error (#77)
Co-authored-by: goekce <git2022@aydos.de>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 11 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f8556d947c0b..a37dac77dbfe 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: acxz <akashpatel2008 at yahoo dot com>
# Contributor: Tim Rakowski <tim.rakowski@gmail.com>
pkgname=ignition-common
-pkgver=5.3.1
-pkgrel=4
+pkgver=5.4.0
+pkgrel=1
pkgdesc="Provides a set of libraries that cover many different use cases."
arch=('x86_64')
url="https://gazebosim.org/libs/common"
@@ -10,11 +10,17 @@ license=('Apache')
depends=('ignition-math>6' 'ignition-utils>1' 'tinyxml2' 'freeimage'
'libutil-linux' 'gts' 'ffmpeg4.4' 'gdal' 'assimp')
makedepends=('ignition-cmake>2' 'util-linux')
-source=("${pkgname}-${pkgver}.tar.gz::https://github.com/gazebosim/gz-common/archive/gz-common5_${pkgver}.tar.gz")
-sha256sums=('dbb7eb6639fec27bb971d0df6a0d17d8076e82a7a7f3cadb570adab02ab7d9ad')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/gazebosim/gz-common/archive/gz-common5_${pkgver}.tar.gz"
+ "gcc13.diff::https://github.com/gazebosim/gz-common/commit/6a0f9d7cd67a3916a0e6661cd99494f2d0e4faf9.patch")
+sha256sums=('e439bac118b145355d57713a975394a6191e4d1d4703566851ddfc7b72463af3'
+ '5c1018b5dd41e1d9af9050e19baad31010e31788663430c48b5aaa2e0cdf0d43')
_dir="gz-common-gz-common5_${pkgver}"
-
+prepare() {
+ # fix GCC13 errors
+ cd "$srcdir/$_dir"
+ patch -p1 < ../gcc13.diff
+}
build() {
cd "$srcdir/$_dir"