summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGonçalo Camelo Neves Pereira2018-05-27 12:05:12 +0100
committerGonçalo Camelo Neves Pereira2018-05-27 12:05:12 +0100
commit83e5897d7300ac20337beb1c95e0d595945b2469 (patch)
tree5a407a216cbb0292ab3edd2f0c3f866b00cf2add /PKGBUILD
parent236759f5524915ace0da4b9d5c3d5465c1646b0c (diff)
downloadaur-83e5897d7300ac20337beb1c95e0d595945b2469.tar.gz
Fix Video.cc error
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD5
1 files changed, 4 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 080ab461c873..a8ebff5f8c97 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Contributor: Tim Rakowski <tim.rakowski@gmail.com>
pkgname=ignition-common
pkgver=1.0.1
-pkgrel=1
+pkgrel=2
pkgdesc="A collection of useful classes and functions for handling many command tasks. This includes parsing 3D mesh files, managing console output, and using PID controllers."
arch=('any')
url="http://ignitionrobotics.org/libs/common"
@@ -19,6 +19,9 @@ _dir="ignitionrobotics-ign-common-21fe175fe91c"
build() {
cd "$srcdir/$_dir"
+ sed -i -e 's/CODEC_CAP_TRUNCATED/AV_CODEC_CAP_TRUNCATED/g' src/Video.cc
+ sed -i -e 's/CODEC_FLAG_TRUNCATED/AV_CODEC_FLAG_TRUNCATED/g' src/Video.cc
+
mkdir -p build
cd build