summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoracxz2019-06-30 09:44:59 -0400
committeracxz2019-06-30 09:44:59 -0400
commitefe43b3ba6e595a528b3b0ab54cacf297c919362 (patch)
tree88fd4819ac474de8d0ab57ba49460a1587e0887a /PKGBUILD
parent62e083ac5e71b9e904b33857606a672b663f6ece (diff)
downloadaur-efe43b3ba6e595a528b3b0ab54cacf297c919362.tar.gz
harder dep requirements and faster compilation
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6cee86510d32..83e8e1b256d2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,14 @@
# Contributor: Tim Rakowski <tim.rakowski@gmail.com>
pkgname=ignition-common
pkgver=3.1.0
-pkgrel=1
+pkgrel=2
pkgdesc="A collection of useful classes and functions for handling many command tasks. This includes parsing 3D mesh files, managing console output, and using PID controllers."
arch=('any')
url="http://ignitionrobotics.org/libs/common"
license=('Apache')
groups=('development')
-makedepends=('ignition-cmake' 'util-linux')
-depends=('ignition-math' 'tinyxml2' 'freeimage' 'libutil-linux' 'gts' 'ffmpeg')
+depends=('ignition-math>=6' 'tinyxml2' 'freeimage' 'libutil-linux' 'gts' 'ffmpeg')
+makedepends=('ignition-cmake>=2' 'util-linux')
optdepends=()
conflicts=()
source=("https://bitbucket.org/ignitionrobotics/ign-common/get/${pkgname}3_${pkgver}.tar.bz2")
@@ -30,7 +30,7 @@ build() {
-DBUILD_TESTING:BOOL=False
# Compile
- make
+ make -j4
}
check() {
@@ -41,7 +41,7 @@ check() {
-DCMAKE_INSTALL_LIBDIR="lib" \
-DBUILD_TESTING:BOOL=True
- make
+ make -j4
make test
}