summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJuliette Cordor2022-06-04 14:38:34 +1000
committerJuliette Cordor2022-06-04 14:38:34 +1000
commit2b648dd2515de00bb514f9bd3147fb2c22985a62 (patch)
treec63972b3d896905bf730a6a07c2c62c08ae21e2f /PKGBUILD
downloadaur-2b648dd2515de00bb514f9bd3147fb2c22985a62.tar.gz
added pkgbuild and srcinfo
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..615e3ac3151f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Juliette Cordor
+pkgname=ignoreit
+pkgver=2.4.2
+pkgrel=1
+url="https://github.com/jewlexx/ignoreit"
+makedepends=('rust' 'cargo')
+arch=('i686' 'x86_64' 'armv6h' 'armv7h')
+pkgdesc="Quickly load .gitignore templates"
+license=('MIT')
+source=(
+ "$pkgname-$pkgver.tar.gz::https://static.crates.io/crates/$pkgname/$pkgname-$pkgver.crate"
+)
+
+sha256sums=('4bcb5d8fcc504cf92a475fd5c785a86383d1402bf3599c63ad346c24a06caed9')
+
+build() {
+ return 0
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ export RUSTUP_TOOLCHAIN=stable
+ cargo install --no-track --all-features --root="$pkgdir/usr/" --path .
+}