summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTom Alexandrowicz2017-01-10 23:41:32 -0500
committerTom Alexandrowicz2017-01-10 23:41:32 -0500
commit3e2cced372494c93449f89e3460160b1c1c58bb0 (patch)
treee9653032d363295ee4c3061d4caf1aeffde8d6a7 /PKGBUILD
parentdc02544c540c1ebfa0538b066e77b279473f2b5f (diff)
downloadaur-3e2cced372494c93449f89e3460160b1c1c58bb0.tar.gz
Include the header file from iguanair when building iguanair-lirc. Also some strange thing about -fPIC because I don't think I know how to add include paths properly
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD2
1 files changed, 1 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c88bd7efe46c..85974b3b883e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -23,7 +23,7 @@ build() {
cd $srcdir/$pkgname
patch -p0 < $startdir/Makefile.patch
- make IGUANADIR="$srcdir/iguanair/software/usb_ir/CMakeFiles/iguanaIR.dir/"
+ make IGUANADIR="$srcdir/iguanair/software/usb_ir" CFLAGS+="-I $srcdir/iguanair/software/usb_ir" CFLAGS+='-D PLUGINDOCS="\"X\""' CFLAGS+='-fPIC'
}
package() {
cd $pkgname