summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLuis Martinez2021-08-08 18:50:21 -0500
committerLuis Martinez2021-08-08 18:50:21 -0500
commit7c26bc26140ed501f9af25f54dbe9228a95f1431 (patch)
treefe2652961cd6640e0add5b4e4c929b522d0d8501 /PKGBUILD
parent1babb9964a92320de809bd130bf109c896b85e75 (diff)
downloadaur-7c26bc26140ed501f9af25f54dbe9228a95f1431.tar.gz
update to 1.3.1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 17 insertions, 17 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b265f0ac2eea..2b4b4316f946 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
-# Maintainer: Luis Martinez <luis dot martinez at tuta dot io>
+# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
pkgname=image-roll-bin
_pkgname="${pkgname%-bin}"
-pkgver=1.2.0
+pkgver=1.3.1
pkgrel=1
pkgdesc="A simple and fast GTK image viewer with basic image manipulation tools"
arch=('x86_64')
@@ -11,25 +11,25 @@ license=('MIT')
depends=('gtk3')
provides=("$_pkgname")
conflicts=("$_pkgname")
-source=("$url/releases/download/$pkgver/$_pkgname-$pkgver"
- "https://raw.githubusercontent.com/weclaw1/$_pkgname/$pkgver/LICENSE"
- "https://raw.githubusercontent.com/weclaw1/$_pkgname/$pkgver/README.md"
- "https://raw.githubusercontent.com/weclaw1/$_pkgname/$pkgver/src/resources/com.github.weclaw1.ImageRoll.desktop"
- "https://raw.githubusercontent.com/weclaw1/$_pkgname/$pkgver/src/resources/com.github.weclaw1.ImageRoll.svg"
- "https://raw.githubusercontent.com/weclaw1/$_pkgname/$pkgver/src/resources/com.github.weclaw1.ImageRoll.metainfo.xml"
+source=("$_pkgname-$pkgver::$url/releases/download/$pkgver/$_pkgname-$pkgver"
+ "LICENSE-$pkgver::https://raw.githubusercontent.com/weclaw1/$_pkgname/$pkgver/LICENSE"
+ "README-$pkgver.md::https://raw.githubusercontent.com/weclaw1/$_pkgname/$pkgver/README.md"
+ "$pkgname-$pkgver.desktop::https://raw.githubusercontent.com/weclaw1/$_pkgname/$pkgver/src/resources/com.github.weclaw1.ImageRoll.desktop"
+ "$pkgname-$pkgver.svg::https://raw.githubusercontent.com/weclaw1/$_pkgname/$pkgver/src/resources/com.github.weclaw1.ImageRoll.svg"
+ "$pkgname-$pkgver.xml::https://raw.githubusercontent.com/weclaw1/$_pkgname/$pkgver/src/resources/com.github.weclaw1.ImageRoll.metainfo.xml"
)
-sha256sums=('d1d200c9cb4a4c6fc5bd06d7a2fd8f180e3fdcd4f1c2d4d7c5f42683edc55db3'
+sha256sums=('cda29ca3ae82d18eecd89ddc2d5aa6df07ea69c97526609b0154990d41a5fa66'
'a05b29c2d3db2d0099c21b8bd50618ae6bfdaf6bb4e92cadd94ae673eb5717c6'
'611335d0701dc46409e3db93b26a45b4ed2840d63941415bc2c46721d353e1e6'
- '4d4db2c0db6213956474759fc02959a78c08c37fa6c8441ee9c068945dd47e5e'
+ '612d93113c9eeeb72137054348743d1edaf68dbeb884b489cd64a60473bf4ee6'
'dd12fa3d3f4c4d64d4c1cdf99fef48b098a6ea069400b4863144f81a4dc8e010'
- 'd831854320f9fef02f964e6672b9826c4c4a73f5d8ecb77ea22e55b6be4fe716')
+ '0a2a12c0ea01e18d76c163b102bf55d6b1fb4b4a688643315fbe1cbbe65b5672')
package() {
- install -Dvm 755 "$_pkgname-$pkgver" "$pkgdir/usr/bin/$_pkgname"
- install -Dvm 644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname/"
- install -Dvm 644 README.md -t "$pkgdir/usr/share/doc/$pkgname/"
- install -Dvm 644 com.github.weclaw1.ImageRoll.desktop -t "$pkgdir/usr/share/applications/"
- install -Dvm 644 com.github.weclaw1.ImageRoll.svg -t "$pkgdir/usr/share/icons/hicolor/scalable/apps/"
- install -Dvm 644 com.github.weclaw1.ImageRoll.metainfo.xml -t "$pkgdir/usr/share/metainfo/"
+ install -Dm 755 "$_pkgname-$pkgver" "$pkgdir/usr/bin/$_pkgname"
+ install -Dm 644 "LICENSE-$pkgver" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm 644 "README-$pkgver.md" "$pkgdir/usr/share/doc/$pkgname/README.md"
+ install -Dm 644 "$pkgname-$pkgver.desktop" "$pkgdir/usr/share/applications/com.github.weclaw1.ImageRoll.desktop "
+ install -Dm 644 "$pkgname-$pkgver.svg" "$pkgdir/usr/share/icons/hicolor/scalable/apps/com.github.weclaw1.ImageRoll.svg"
+ install -Dm 644 "$pkgname-$pkgver.xml" "$pkgdir/usr/share/metainfo/com.github.weclaw1.ImageRoll.metainfo.xml"
}