summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorlilac2019-07-22 01:53:26 +0800
committerlilac2019-07-22 01:53:26 +0800
commitf59ccdeaaee358131cf8b01c913c6db40f2453f2 (patch)
tree7647810a58900988887414d8da514a4cb77a5d8a /PKGBUILD
parentc6feaf955b3eb783a9c271ac57067f31354bbe6b (diff)
downloadaur-f59ccdeaaee358131cf8b01c913c6db40f2453f2.tar.gz
update by lilac
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 8 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index dc7149989c58..8986cb3eb95a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgbase=imagemagick-fftw
pkgname=(imagemagick-fftw)
-pkgver=7.0.8.55
+pkgver=7.0.8.56
pkgrel=1
pkgdesc="An image viewing/manipulation program"
url="https://www.imagemagick.org/"
@@ -15,11 +15,10 @@ checkdepends=(gsfonts ttf-dejavu)
_relname=ImageMagick-${pkgver%%.*}
_tarname=ImageMagick-${pkgver%.*}-${pkgver##*.}
source=(https://www.imagemagick.org/download/releases/$_tarname.tar.xz{,.asc}
- arch-fonts.diff IM7-GS-policy.patch)
-sha256sums=('2ae7274fddbf65c4e084d3c0c87a0b1270b34f978d5358d5a54f1b3dae5ec152'
+ arch-fonts.diff)
+sha256sums=('b1f32fed2bf0a28a7553f7ac1afc86d02ee35587408d2a89916e3072d9f8d532'
'SKIP'
- 'a85b744c61b1b563743ecb7c7adad999d7ed9a8af816650e3ab9321b2b102e73'
- 'f20c09860da65a4259ec9627ceeca7d993949b7460fa199c5ffd874633814cf6')
+ 'a85b744c61b1b563743ecb7c7adad999d7ed9a8af816650e3ab9321b2b102e73')
validpgpkeys=(D8272EF51DA223E4D05B466989AB63D48277377A) # Lexie Parsimoniae
shopt -s extglob
@@ -31,9 +30,6 @@ prepare() {
# Fix up typemaps to match our packages, where possible
patch -p1 -i ../arch-fonts.diff
-
- # Work around ghostscript security issues https://bugs.archlinux.org/task/59778
- patch -p1 -i ../IM7-GS-policy.patch
}
build() {
@@ -48,7 +44,7 @@ build() {
PCLDelegate=/usr/bin/gpcl6 \
--enable-hdri \
--enable-opencl \
- --with-gslib \
+ --without-gslib \
--with-lqr \
--with-modules \
--with-openexr \
@@ -73,7 +69,6 @@ build() {
check() (
cd $_tarname
ulimit -n 4096
- sed -e '/validate-formats/d' -i Makefile # these fail due to the security patch
make check
)
@@ -108,5 +103,8 @@ package_imagemagick-fftw() {
# Split docs
mv "$pkgdir/usr/share/doc" "$srcdir/docpkg/usr/share/"
+
+# Harden security policy https://bugs.archlinux.org/task/62785
+ sed -e '/<\/policymap>/i \ \ <policy domain="delegate" rights="none" pattern="gs" \/>' -i "$pkgdir"/etc/ImageMagick-7/policy.xml
}