summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDaniel Bermond2016-12-03 16:48:44 -0200
committerDaniel Bermond2016-12-03 16:48:44 -0200
commit474df8ebc1b5ce11d85b96ae75cc7991c17a5712 (patch)
treeb706be93a8e232c78e003b60ed47d653fe897e39 /PKGBUILD
parenta0bf46e040e6e843ae769e253679ae15b85679c6 (diff)
downloadaur-474df8ebc1b5ce11d85b96ae75cc7991c17a5712.tar.gz
opencl dependecy changes
In short: depends: changed from ocl-icd to opencl-icd-loader. Moved opencl-headers to makedepends. The long story: This will match the approach used in PKGBUILDs from many repository packages that depends on opencl. These packages doesn't place a direct dependency to package ocl-icd like we were doing here, but instead they depends on libcl or on opencl-icd-loader that is provided by ocl-icd. The imagemagick repository package uses this approach. Also, opencl-headers is not needed at runtime and should be placed in makedepens. It's hard to tell for which one we should replace ocl-icd (if for libcl or for opencl-icd-loader), since, among other things, some repository packages points to libcl and others to opencl-icd-loader. In a recent update the imagemagick repository package has changed dependency from libcl to opencl-icd-loader, so we will be using opencl-icd-loader here too. Reference: https://git.archlinux.org/svntogit/packages.git/commit/trunk?h=packages/imagemagick&id=193cd1967d79f4de07019e94cda75aaff9947a3d
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ef6ddbae829e..fde4714259d0 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -27,7 +27,7 @@ _srcver=$(curl -s "$_digest" | grep -o "${_srcname}-7[0-9\.-]*\.tar\.xz" | sed '
_srcverregex=$(echo "$_srcver" | sed 's/\./\\\./g') # translate source version to a regular expression
pkgname=imagemagick-full
pkgver=$(echo "$_srcver" | tr '-' '.')
-pkgrel=1
+pkgrel=2
pkgdesc="An image viewing/manipulation program (Q32 HDRI with all libs and features)"
arch=('i686' 'x86_64')
url="http://www.imagemagick.org/"
@@ -35,8 +35,9 @@ license=('custom')
depends=('jemalloc' 'bzip2' 'libx11' 'libxext' 'libxt' 'libsm' 'zlib' 'autotrace-nomagick' 'fftw' 'flif-git'
'libfpx' 'djvulibre' 'ttf-dejavu' 'fontconfig' 'freetype2' 'libraqm' 'ghostscript' 'gsfonts'
'graphviz' 'jbigkit' 'libjpeg-turbo' 'lcms' 'lcms2' 'openjpeg2' 'liblqr' 'xz' 'openexr' 'pango'
- 'libpng' 'librsvg' 'libtiff' 'libwebp' 'libwmf' 'libxml2' 'libmpeg2' 'opencl-headers' 'ocl-icd')
+ 'libpng' 'librsvg' 'libtiff' 'libwebp' 'libwmf' 'libxml2' 'libmpeg2' 'opencl-icd-loader')
optdepends=('ttf-mac-fonts: for Apple fonts support')
+makedepends=('opencl-headers')
provides=("imagemagick"
"libMagickCore-${pkgver%%.*}.Q32HDRI.so"
"libMagickWand-${pkgver%%.*}.Q32HDRI.so"