summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDaniel Bermond2018-03-18 03:36:08 +0000
committerDaniel Bermond2018-03-18 03:36:08 +0000
commit48cdbdb74302ac47cc7a464dd479e8bd62ab8154 (patch)
tree1c9382865add7a102ac88ee13e2fbd7967bc236b /PKGBUILD
parent25b45406993e83b8edcad8f3474378b30ba1079a (diff)
downloadaur-48cdbdb74302ac47cc7a464dd479e8bd62ab8154.tar.gz
Avoid running configure twice
When using the git tree source, configure runs twice: for some reason it needs to do a recheck and runs for a second time. Remaking all the configuration files by running 'autoreconf -fis' will fix it.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 8 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ea614ac4420b..b0d34c86d396 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -28,7 +28,7 @@ _qdepth='32'
pkgbase=imagemagick-full
pkgname=('libmagick-full' 'imagemagick-full' 'imagemagick-full-doc')
pkgver=7.0.7.27
-pkgrel=1
+pkgrel=2
arch=('i686' 'x86_64')
pkgdesc="An image viewing/manipulation program (Q${_qdepth} HDRI with all libs and features)"
url='http://www.imagemagick.org/'
@@ -63,6 +63,9 @@ sha256sums=('SKIP'
prepare() {
cd "${pkgbase}-git"
+ # fix for 'sh: gitversion.sh: command not found' during autoreconf
+ sed -i 's|(gitversion|(./gitversion|' configure.ac
+
# fix up typemaps to match Arch Linux packages, where possible
patch -Np1 -i "${srcdir}/arch-fonts.diff"
}
@@ -70,7 +73,10 @@ prepare() {
build() {
cd "${pkgbase}-git"
- CFLAGS="${CFLAGS} -I/usr/include/FLIF" \
+ export CFLAGS="${CFLAGS} -I/usr/include/FLIF"
+
+ autoreconf -fis
+
./configure \
--prefix='/usr' \
--sysconfdir='/etc' \