summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDaniel Bermond2019-07-14 14:19:07 +0000
committerDaniel Bermond2019-07-14 14:19:07 +0000
commitc67a88f95e3bacc1402bf0e8d69d6c66aaa7403f (patch)
tree221ca10218a9a073bcf9a947836f6ee3b254318b /PKGBUILD
parent5226f1c0a6b800a3540bc2bcf1afe5c28d6d403a (diff)
downloadaur-c67a88f95e3bacc1402bf0e8d69d6c66aaa7403f.tar.gz
Updated to version 7.0.8.53
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 18 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2722b3fd4275..324f59427670 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,13 +10,13 @@
# - deJaVu and GhostScript font directories are the default ones
# - Windows font directory is set according to a Wiki example
-_commit='ec9498c7945dc0700e09e2d2ad458379251969e1'
+_commit='4907e6feafa4b89d5cc38125280e33f2101b242e'
_qdepth='32'
pkgbase=imagemagick-full
pkgname=('imagemagick-full' 'imagemagick-full-doc')
_srcname=ImageMagick
-pkgver=7.0.8.49
+pkgver=7.0.8.53
pkgrel=1
arch=('x86_64')
pkgdesc="An image viewing/manipulation program (Q${_qdepth} HDRI with all libs and features)"
@@ -34,13 +34,14 @@ makedepends=(
# AUR:
'pstoedit-nomagick' 'autotrace-nomagick' 'flif' 'libfpx' 'libumem-git'
)
-BUILDENV+=('!check')
source=("git+https://github.com/ImageMagick/ImageMagick.git#commit=${_commit}"
'imagemagick-full-security-fix.patch'
- 'arch-fonts.diff')
+ 'arch-fonts.diff'
+ 'imagemagick-full-disable-avaraging-tests.patch')
sha256sums=('SKIP'
'e2453381d283c33107194fa791d6b9b2c4c1856afb936d4fa010c05aaebe538e'
- 'a85b744c61b1b563743ecb7c7adad999d7ed9a8af816650e3ab9321b2b102e73')
+ 'a85b744c61b1b563743ecb7c7adad999d7ed9a8af816650e3ab9321b2b102e73'
+ '2ff7366526a705b195074438266064fb1d347552707bf7bbca739d5eb0c65db9')
prepare() {
cd "$_srcname"
@@ -57,6 +58,11 @@ prepare() {
# fix up typemaps to match Arch Linux packages, where possible
patch -Np1 -i "${srcdir}/arch-fonts.diff"
+ # disable a test that is failing
+ ## https://github.com/ImageMagick/ImageMagick/issues/1570
+ ## https://github.com/ImageMagick/ImageMagick/issues/1576
+ patch -Np1 -i "${srcdir}/imagemagick-full-disable-avaraging-tests.patch"
+
# fix for 'sh: gitversion.sh: command not found' during autoreconf
sed -i 's|(gitversion|(./gitversion|' configure.ac
@@ -66,7 +72,7 @@ prepare() {
build() {
cd "$_srcname"
- export CFLAGS="${CFLAGS} -I/usr/include/FLIF"
+ export CFLAGS+=' -I/usr/include/FLIF'
./configure \
--prefix='/usr' \
@@ -132,12 +138,12 @@ build() {
}
check() (
- cd "$_srcname"
-
- ulimit -n 4096
- sed -e '/validate-formats/d' -i Makefile # these fail due to the security patch
-
- make check
+ cd "$_srcname"
+
+ ulimit -n 4096
+ sed -e '/validate-formats/d' -i Makefile # these fail due to the security patch
+
+ make check
)
package_imagemagick-full() {