summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDaniel Bermond2016-12-19 14:59:49 -0200
committerDaniel Bermond2016-12-19 14:59:49 -0200
commitd357a48ed460dde056a76403ffa6501a16e6b928 (patch)
treeda7dd8096254d487a7f9f6116707849919f91715 /PKGBUILD
parentee7e287159f091ba98e04c2e4721bf76878a396d (diff)
downloadaur-d357a48ed460dde056a76403ffa6501a16e6b928.tar.gz
Updated to version 7.0.4.0
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD6
1 files changed, 4 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3bf28ad954b5..6b37ad054837 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -25,11 +25,13 @@ _digest="http://www.imagemagick.org/download/digest.rdf"
_srcname="ImageMagick"
_srcver="$(curl -s "$_digest" | grep -o "${_srcname}-7[0-9\.-]*\.tar\.xz" | \
sed 's/[^0-9\.-]*//g' | \
- sed -r 's/.//;s/.{2}$//')"
+ sed -r 's/.//;s/.{2}$//' | \
+ sort -r | \
+ head -n1)"
_srcverregex="$(echo "$_srcver" | sed 's/\./\\\./g')" # translate to a regular expression
pkgname=imagemagick-full
pkgver="$(echo "$_srcver"| tr '-' '.')"
-pkgrel=3
+pkgrel=1
pkgdesc="An image viewing/manipulation program (Q32 HDRI with all libs and features)"
arch=('i686' 'x86_64')
url="http://www.imagemagick.org/"