summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBermond2016-07-09 12:14:13 -0300
committerBermond2016-07-09 12:14:13 -0300
commit39ec3df78713c8ccfb2d89abacb0da6faeadfe0e (patch)
tree6048118612315a62ebae135e245a83e5874e0907 /PKGBUILD
parent96f337a8d64405bbab1d9c16495ab290687400fc (diff)
downloadaur-39ec3df78713c8ccfb2d89abacb0da6faeadfe0e.tar.gz
Added Apple fonts support (optional due to licensing issues)
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD14
1 files changed, 10 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3cf1fefeefb5..8147efd7e7f7 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,14 +13,17 @@
# This Windows font directory example is for people that copy/link fonts from a Windows
# installation. If you prefer, you can choose an AUR package that provides the Windows fonts
# as described in the Wiki and change the directory accordingly.
-
+# Apple fonts through AUR package 'tff-mac-fonts' are optional due to licensing issues. It
+# places fonts in directories '/usr/share/fonts/TTF' and '/usr/share/fonts/Type1'.
_dejavu_font_dir="/usr/share/fonts/TTF"
_gs_font_dir="/usr/share/fonts/Type1"
_windows_font_dir="/usr/share/fonts/WindowsFonts"
+_1st_apple_font_dir="/usr/share/fonts/TTF"
+_2nd_apple_font_dir="/usr/share/fonts/Type1"
pkgname=imagemagick-full-git
-pkgver=7.0.2.3.r11035.g32b5039
-pkgrel=4
+pkgver=7.0.2.3.r11068.g82a1df8
+pkgrel=1
pkgdesc="An image viewing/manipulation program (Q32 HDRI with all libs and features, Git version)"
arch=('i686' 'x86_64')
url="http://www.imagemagick.org/"
@@ -29,6 +32,7 @@ depends=('jemalloc' 'bzip2' 'libx11' 'libxext' 'libxt' 'libsm' 'zlib' 'autotrace
'libfpx' 'djvulibre' 'ttf-dejavu' 'fontconfig' 'freetype2' 'libraqm' 'ghostscript' 'gsfonts'
'graphviz' 'jbigkit' 'libjpeg-turbo' 'lcms' 'lcms2' 'openjpeg2' 'liblqr' 'xz' 'openexr' 'pango'
'libpng' 'librsvg' 'libtiff' 'libwebp' 'libwmf' 'libxml2' 'libmpeg2' 'opencl-headers' 'ocl-icd')
+optdepends=('ttf-mac-fonts: for Apple fonts support')
makedepends=('git')
provides=("imagemagick" "imagemagick-full" "imagemagick-git" "imagemagick-fftw"
"libMagickCore-${pkgver%%.*}.Q32HDRI.so"
@@ -120,7 +124,9 @@ build() {
--with-xml \
--with-dejavu-font-dir="$_dejavu_font_dir" \
--with-gs-font-dir="$_gs_font_dir" \
- --with-windows-font-dir="$_windows_font_dir"
+ --with-windows-font-dir="$_windows_font_dir" \
+ --with-apple-font-dir="$_1st_apple_font_dir" \
+ --with-fontpath="$_2nd_apple_font_dir"
make
}