summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorHyacinthe Cartiaux2013-08-09 17:10:40 +0200
committerHyacinthe Cartiaux2015-06-09 14:05:03 +0200
commitfe64aa61b0483e4753ea87be6a16db9f3519bf7f (patch)
treea0b0a3156c131596c3e1f9ac1914df6eb1e23ee3 /PKGBUILD
downloadaur-fe64aa61b0483e4753ea87be6a16db9f3519bf7f.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9288eb93ef6d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Hyacinthe Cartiaux <hyacinthe.cartiaux@free.fr>
+# Contributor: Mark Foxwell <fastfret79@archlinux.org.uk>
+# Contributor: morwel <rt dot riedel at web dot de>
+# Contributor: bct <bct at diffeq dot com>
+
+pkgname=imapfilter
+pkgver=2.5.5
+pkgrel=1
+pkgdesc="A mail filtering utility for processing IMAP mailboxes"
+arch=('i686' 'x86_64')
+url="https://github.com/lefcha/imapfilter"
+license=('MIT')
+depends=('lua' 'pcre' 'openssl')
+optdepends=('openssl: SSL/TLS encryption and CRAM-MD5 authentication')
+source=("https://codeload.github.com/lefcha/${pkgname}/tar.gz/v${pkgver}")
+md5sums=('719b7f606948699d5f057e3a62e6c666')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ # sometimes imapfilter doesn't compile with LDFLAG "--as-needed".
+ # in that case, uncomment next line.
+ # LDFLAGS="-Wl,--hash-style=gnu -Wl"
+
+ make PREFIX=/usr all
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ make PREFIX=/usr DESTDIR="$pkgdir/" MANDIR=/usr/share/man install
+
+ # install sample files
+ install -D -m644 samples/config.lua $pkgdir/usr/share/$pkgname/samples/config.lua
+ install -D -m644 samples/extend.lua $pkgdir/usr/share/$pkgname/samples/extend.lua
+
+ # install license
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}