summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorHurricanePootis2022-05-09 23:02:09 -0500
committerHurricanePootis2022-05-09 23:02:09 -0500
commit57c6a420485f0144d537f234206d51d6668a184d (patch)
tree6f07205c2913117ba53b7ba5032f579a70d772dc /PKGBUILD
parentb0b3efc4255fa45158b83d642e10eb7fe2333b36 (diff)
downloadaur-57c6a420485f0144d537f234206d51d6668a184d.tar.gz
Miniscual improvements
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 6 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c90b9c43e456..2bbd4f5f81fc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: HurricanePootis <hurricanepootis@protonmail.com>
pkgname=imgbrd-grabber
pkgver=7.8.1
-pkgrel=1
+pkgrel=2
pkgdesc="Very customizable imageboard/booru downloader with powerful filenaming features."
arch=('x86_64')
url="https://github.com/Bionus/imgbrd-grabber"
@@ -32,13 +32,17 @@ prepare() {
}
build() {
+ cd "$srcdir/${pkgname}/src/sites" && npm install --no-optional
+
mkdir -p "$srcdir/build"
cd "$srcdir/build"
cmake "$srcdir/${pkgname%}/src" \
-DCMAKE_INSTALL_PREFIX=/usr \
-DUSE_QSCINTILLA=0 \
- -DUSE_BREAKPAD=O
+ -DUSE_BREAKPAD=O \
+ -Wno-dev
+
make
}