summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorHurricanePootis2023-02-23 02:25:25 -0600
committerHurricanePootis2023-02-23 02:25:25 -0600
commit9cc5898d53896183ee0a05dbc6261d0db66bce0e (patch)
treeb9c021eff4e8fef136af9d8fb0a42ebdea8a3bdf /PKGBUILD
parent4bad3723dedc4035e0f6ddbe1bad7c9d4c416468 (diff)
downloadaur-9cc5898d53896183ee0a05dbc6261d0db66bce0e.tar.gz
Improve cmake style
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 6 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 77f302139e18..1ede9917d0d9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: HurricanePootis <hurricanepootis@protonmail.com>
pkgname=imgbrd-grabber
pkgver=7.10.1
-pkgrel=1
+pkgrel=2
pkgdesc="Very customizable imageboard/booru downloader with powerful filenaming features."
arch=('x86_64')
url="https://github.com/Bionus/imgbrd-grabber"
@@ -35,21 +35,21 @@ build() {
npm install --no-optional
- mkdir -p "$srcdir/build" && cd "$srcdir/build"
+ cd "$srcdir"
- cmake "$srcdir/${pkgname%}/src" \
+ cmake -S $pkgname/src -B build \
-DCMAKE_INSTALL_PREFIX=/usr \
-DUSE_QSCINTILLA=0 \
-DUSE_BREAKPAD=O \
-Wno-dev
- make
+ cmake --build build
}
package() {
- cd "$srcdir/build"
+ cd "$srcdir"
- make DESTDIR="$pkgdir/" install
+ DESTDIR="$pkgdir/" cmake --install build
touch "$pkgdir/usr/share/Grabber/settings.ini"
}