summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorZach2016-10-04 13:21:33 -0600
committerZach2016-10-04 13:21:33 -0600
commit86a85013465ccc29cbfd61b3af789d1dadf68b34 (patch)
treef0c38a7b6c1307ed39403105b76c790cf16a35b3 /PKGBUILD
downloadaur-86a85013465ccc29cbfd61b3af789d1dadf68b34.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 20 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..91e9b556c1a0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: zach <zach {at} zach-adams {dot} com>
+
+pkgname=imgp
+_pkgname=imgp
+_pkgauthor=jarun
+pkgver=2.1
+pkgrel=1
+pkgdesc="Resize or rotate JPEG and PNG images. Official releases only."
+arch=('any')
+url="https://github.com/${_pkgauthor}/${_pkgname}"
+license=('GPL3')
+depends=('python3' 'python-pillow')
+source=("https://github.com/${_pkgauthor}/${_pkgname}/archive/v$pkgver.tar.gz")
+conflicts=('imgp-git')
+provides=('imgp')
+sha256sums=('6749bab82ed07ab6a44f7c7b8e9d5e90ea1a82382f4fa26e27392c7a2b5620ea')
+
+package() {
+ make -C "${_pkgname}-$pkgver" DESTDIR="${pkgdir}" PREFIX="/usr" install
+}