summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFrederic Bezies2021-03-20 14:56:18 +0100
committerFrederic Bezies2021-03-20 14:56:18 +0100
commitc90a41317fec3805b9d4c23d1831c3e852949a4a (patch)
treebc8f28840d2dc1b9999d63a56f157edc018b91c8 /PKGBUILD
parent31827d61ef6f3acf4db018c4352711bafbab70f8 (diff)
downloadaur-c90a41317fec3805b9d4c23d1831c3e852949a4a.tar.gz
March 20th, 2021 update
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 8 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f6fbd914e43e..597a76a4642f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,26 @@
-# Maintainer: zach <zach {at} zach-adams {dot} com>
+# Maintainer: Frederic Bezies < fredbezies at gmail dot com >
+# Contributor: zach <zach {at} zach-adams {dot} com>
pkgname=imgp-git
_pkgname=imgp
-_pkgauthor=jarun
-pkgver=141.ac30556
+pkgver=r257.96269dd
pkgrel=1
pkgdesc="Resize or rotate JPEG and PNG images."
arch=('any')
-url="https://github.com/${_pkgauthor}/${_pkgname}"
+url="https://github.com/jarun/${_pkgname}"
license=('GPL3')
depends=('python3' 'python-pillow')
makedepends=('git')
-source=(${_pkgname}::"git+https://github.com/${_pkgauthor}/${_pkgname}.git")
+source=(${_pkgname}::"git+https://github.com/jarun/${_pkgname}.git")
sha256sums=('SKIP')
conflicts=('imgp')
provides=('imgp')
pkgver() {
- cd "${srcdir}/${_pkgname}"
- echo "$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
+ cd "$_pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
package() {
- make -C "${srcdir}/${_pkgname}" DESTDIR="${pkgdir}" PREFIX="/usr" install
+ make -C "${srcdir}/${_pkgname}" DESTDIR="${pkgdir}" PREFIX="/usr" install
}