summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authornezumisama2015-06-14 18:09:06 +0200
committernezumisama2015-06-14 18:09:06 +0200
commit96284f2d2b466edb9e4cb4f7f90386a5c03a2fa3 (patch)
treee3579ae88a4a0c48660aee1450c11665cb4a04c9 /PKGBUILD
downloadaur-96284f2d2b466edb9e4cb4f7f90386a5c03a2fa3.tar.gz
Initial commit.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..583df0dbce47
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Contributor: Robert Emil Berge <robert@rebi.no>
+# Maintainer: AppleBloom <rat.o.drat@gmail.com>
+# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
+
+pkgname=imgseek
+pkgver=0.8.6
+pkgrel=9
+pkgdesc="a photo collection manager and viewer with content-based search and many other features"
+url="http://www.imgseek.net"
+depends=('pyqt3' 'imagemagick' 'python-imaging')
+arch=('i686' 'x86_64')
+license=('GPL')
+source=("http://downloads.sourceforge.net/sourceforge/imgseek/imgSeek-$pkgver.tar.bz2"
+ "python27.patch"
+ "make_it_work.patch")
+md5sums=('4b311475b51be649deb45afd6a12eaa2'
+ '18757ccbd513081228e993d6221060c1'
+ 'efab62e2f1b21196060e07293fe2dc1c')
+
+_dir="imgSeek-$pkgver"
+
+prepare() {
+ cd "$_dir"
+ patch -p1 -i ../make_it_work.patch
+ patch -p1 -i ../python27.patch
+}
+
+build() {
+ cd "$_dir"
+ python2 setup.py build
+}
+
+package() {
+ cd "$_dir"
+ python2 setup.py install --prefix="$pkgdir"/usr
+ cd "$pkgdir"/usr/lib/python2.7/site-packages/imgSeekLib
+ ln -s ImageDB.py ImgDB.py
+}