summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMichel Zou2021-03-01 13:38:47 +0100
committerMichel Zou2021-03-01 13:38:47 +0100
commitdf4d670eb7d75452d690afe51151a99fc4020314 (patch)
tree50788d2c6fe0dedc4540ccbfb7b3aa5fd2102556 /PKGBUILD
downloadaur-df4d670eb7d75452d690afe51151a99fc4020314.tar.gz
1.81
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..73b6c1f4d038
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+pkgname=imgui
+pkgver=1.81
+pkgrel=1
+pkgdesc="Bloat-free Graphical User interface for C++"
+license=('MIT')
+arch=('x86_64')
+url="https://github.com/ocornut/imgui"
+depends=('gcc-libs')
+makedepends=('cmake')
+source=("https://github.com/ocornut/imgui/archive/v${pkgver}.tar.gz")
+sha256sums=('f7c619e03a06c0f25e8f47262dbc32d61fd033d2c91796812bf0f8c94fca78fb')
+
+prepare() {
+ cd $pkgname-$pkgver
+ wget https://raw.githubusercontent.com/microsoft/vcpkg/master/ports/imgui/CMakeLists.txt
+ wget https://raw.githubusercontent.com/microsoft/vcpkg/master/ports/imgui/imgui-config.cmake.in
+}
+
+
+build() {
+ cd $pkgname-$pkgver
+ mkdir -p build && cd build
+ cmake -DCMAKE_INSTALL_PREFIX=/usr -DBUILD_SHARED_LIBS=ON ..
+ make
+}
+
+package() {
+ cd $pkgname-$pkgver/build
+ make DESTDIR="$pkgdir" install
+}
+