summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlec Mev2021-04-02 11:20:52 +0100
committerAlec Mev2021-04-02 11:20:52 +0100
commit0d30b98a28bbceccdb973e2bb6ca941938a09005 (patch)
tree1ac00c5b2e4196e057277d2fe26e43cca3041c9f /PKGBUILD
parenta1924e335012d4d150e0edd55974d0db241d384c (diff)
downloadaur-0d30b98a28bbceccdb973e2bb6ca941938a09005.tar.gz
3.2, add wl-clipboard
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 19 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8817b2426314..6ab17f19cfac 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,26 @@
-# Maintainer: Ramon <https://github.com/ram-on/imgurbash2>
+# Maintainer: Alec Mev <alec@mev.earth>
+# Contributor: NightSong <ramif.47@gmail.com>
pkgname=imgurbash2
-pkgver=3.1
-pkgrel=5
-pkgdesc="A small shell script that uploads/deletes images to/from imgur.com"
+pkgver=3.2
+pkgrel=1
+pkgdesc='A shell script that uploads/deletes images to/from IMGUR'
arch=('any')
-url="https://github.com/ram-on/imgurbash2"
+url='https://github.com/ram-on/imgurbash2'
license=('MIT')
-depends=('curl')
-optdepends=('xsel: automatically putting the URL on the X selection for easy pasting'
- 'xclip: an alternative to xsel')
-source=("https://github.com/ram-on/imgurbash2/archive/${pkgver}.tar.gz")
-sha256sums=('e66e27b96d303a7896d2b4c8abc4dca4974193eebb3851e4ee0b88076b703809')
+depends=('bash' 'curl')
+optdepends=(
+ 'wl-clipboard: To be able to copy image URL to clipboard in Wayland'
+ 'xclip: To be able to copy image URL to clipboard in X'
+ 'xsel: To be able to copy image URL to clipboard in X'
+)
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/ram-on/imgurbash2/archive/${pkgver}.tar.gz")
+sha256sums=('a17ef6c96399550293ee806bae4665e4353c3280df4d3ebe041cf589fe6bc259')
package() {
- cd "$pkgname-$pkgver"
- install -D -m 755 ${pkgname} "${pkgdir}/usr/bin/${pkgname}"
- install -D -m 644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ cd "${pkgname}-${pkgver}"
+ install -Dm755 -t "${pkgdir}/usr/bin/" "${pkgname}"
+ install -Dm644 -t "${pkgdir}/usr/share/doc/${pkgname}" README.md
+ install -Dm644 -t "${pkgdir}/usr/share/doc/${pkgname}" examples.md
+ install -Dm644 -t "${pkgdir}/usr/share/licenses/${pkgname}" LICENSE
}