summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKokaKiwi2021-09-30 13:20:51 +0200
committerKokaKiwi2021-09-30 13:20:51 +0200
commit19350099704d39430d77e747b967a463e26554c2 (patch)
tree6773dcb7c321c4200c926862e7c1de60c0a90b80 /PKGBUILD
parent54205d98f9b1d368668ffd0e1c8d0e1ad32fa445 (diff)
downloadaur-19350099704d39430d77e747b967a463e26554c2.tar.gz
Update: 1.10.1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 8 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1cc19b6cb132..f21c62973f08 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
_pkgname=ImHex
pkgname=${_pkgname,,}
-pkgver=1.10.0
-pkgrel=2
+pkgver=1.10.1
+pkgrel=1
pkgdesc='A Hex Editor for Reverse Engineers, Programmers and people that value their eye sight when working at 3 AM'
url='https://github.com/WerWolv/ImHex'
license=('GPL2')
@@ -16,36 +16,31 @@ makedepends=('git' 'cmake' 'glm' 'llvm' 'nlohmann-json' 'librsvg')
source=("${pkgname}::git+https://github.com/WerWolv/ImHex.git#tag=v${pkgver}"
"nativefiledialog::git+https://github.com/btzy/nativefiledialog-extended.git"
"git+https://git.sr.ht/~danyspin97/xdgpp"
- 0001-build-Fix-system-libraries-usage.patch
imhex.desktop)
cksums=('SKIP'
'SKIP'
'SKIP'
- '2019546358'
'4178124713')
sha256sums=('SKIP'
'SKIP'
'SKIP'
- '25f2b3fe49d0c75207ad561995a3ad24b45581cad878c04922402d3d60e98ef1'
'72525512a241589cecd6141f32ad36cbe1b5b6f2629dd8ead0e37812321bdde6')
b2sums=('SKIP'
'SKIP'
'SKIP'
- '00982d536e4623a47acdc648d53a97fe4eb64e1a19f807b7a1a5aa66cda5056100cc9bc968a2c914f64e924c0beb47d5443dcb013c858d30af8a24c16e0a82bf'
'7b2d029de385fdc2536f57a4364add9752b9a5dc31df501e07bff1fd69fdd1de2afa19a5ac5a4c87fbf21c5d87cc96d3fe30d58825c050f5a7d25f6d85d08efc')
prepare() {
- git -C "$pkgname" submodule init
+ cd "$pkgname"
+
+ git submodule init
for name in nativefiledialog xdgpp; do
- git -C "$pkgname" config submodule.external/$name.url "$srcdir/$name"
+ git config submodule.external/$name.url "$srcdir/$name"
done
for name in yara/yara fmt curl; do
- git -C "$pkgname" config --remove-section submodule.external/$name
+ git config --remove-section submodule.external/$name
done
- git -C "$pkgname" submodule update
-
- git -C "$pkgname" apply -v \
- "$srcdir/0001-build-Fix-system-libraries-usage.patch"
+ git submodule update
}
build() {