summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKokaKiwi2022-04-18 11:43:13 +0200
committerKokaKiwi2022-04-18 11:43:13 +0200
commit3e3670cbf6a3ec9f2bd1c5e0e51511d3e2767401 (patch)
treeffc472ab422ecf88f8ef72c45c72db63db1ed7f4 /PKGBUILD
parentde81a5c27536c740678309f66fb91aa879db887c (diff)
downloadaur-3e3670cbf6a3ec9f2bd1c5e0e51511d3e2767401.tar.gz
Update: 1.17.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD42
1 files changed, 21 insertions, 21 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b7ba3e71482c..9fe90af6f68b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,15 +3,15 @@
_pkgname=ImHex
pkgname=${_pkgname,,}
-pkgver=1.16.2
-pkgrel=2
+pkgver=1.17.0
+pkgrel=1
pkgdesc='A Hex Editor for Reverse Engineers, Programmers and people that value their eye sight when working at 3 AM'
url='https://github.com/WerWolv/ImHex'
license=('GPL2')
arch=('x86_64')
depends=('glfw' 'mbedtls' 'libssh2'
'python' 'freetype2' 'file' 'gtk3' 'hicolor-icon-theme' 'openssl'
- 'yara' 'fmt')
+ 'fmt')
makedepends=('git' 'cmake' 'glm' 'llvm' 'nlohmann-json' 'librsvg')
optdepends=('imhex-patterns-git: ImHex base patterns')
source=("$pkgname::git+https://github.com/WerWolv/ImHex.git#tag=v$pkgver"
@@ -19,46 +19,51 @@ source=("$pkgname::git+https://github.com/WerWolv/ImHex.git#tag=v$pkgver"
"xdgpp::git+https://git.sr.ht/~danyspin97/xdgpp"
"libromfs::git+https://github.com/WerWolv/libromfs"
"capstone::git+https://github.com/capstone-engine/capstone#branch=next"
+ "pattern_language::git+https://github.com/WerWolv/PatternLanguage"
+ "yara::git+https://github.com/VirusTotal/yara#tag=v4.2.0"
0001-makepkg-Remove-external-stuff.patch
0002-archlinux-compat-Remove-unused-mbedTLS-code-from-lib.patch
- libromfs-0001-Fix-code-generation-for-clang.patch
imhex.desktop)
cksums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
'SKIP'
- '948907946'
- '345460920'
- '2244423799'
+ 'SKIP'
+ 'SKIP'
+ '1548749629'
+ '3307749664'
'4178124713')
sha256sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
'SKIP'
- '9135ba8227955249554983f680f0bbf3b5a615182f8913af1c5b0f8890a6c9dd'
- 'daf80fbf00f91a2dafa972c644fc5ab7fc43438e1a3d86515f7b1fa0e2ff1d13'
- '5df68c1ee84ef55b07860b3b37120a21f488bbf9bff9466eb45fe81e537cd611'
+ 'SKIP'
+ 'SKIP'
+ '9969198e1130e4db97991006ce033cc94cb001e5088efbf3235d13b247c52604'
+ '781b1747305ba9692477b5237af166b4ce521ceaffb8d985378958e521923811'
'72525512a241589cecd6141f32ad36cbe1b5b6f2629dd8ead0e37812321bdde6')
b2sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
'SKIP'
- 'fe7d4248ab3cb04d7b78bd9b179a1fb06239c093c9960de30573e56bdddc0da993481e51fac5fad629510d0d75cac0b367ef1c8d23d58406fc5a1c4400920271'
- 'f694d8af5d577a5d3566efa70b391518d858ecb1743450e4c75a509ba9a5ee13a0de4b4bff260b569202d77a49d35bba4f04a25b105616b591775d93f29d6b4e'
- 'faa552370acc478ab155125fc029049edab8d105496201ec3763dfa5af3dc71ab334bd53545231e172643d51a4470db1a3d3573de007590bd88efe5ebef2fb44'
+ 'SKIP'
+ 'SKIP'
+ 'e3cadb16e6e98752fa7bd4db71352b0daa9726cb23017bd2115d353b9b8b435287c1b8e75bcc57baaa058cf42e8cb3dbf097d13224749fddaf670c001ac8361c'
+ '9be8392e2035f5438da66b87c7738ed4bdef83ae73145e35a5086655d0ebbaa87b4dae801d44d3cbdf6f39bbce879583aa1195b414d4afa519de28f3df1185bc'
'7b2d029de385fdc2536f57a4364add9752b9a5dc31df501e07bff1fd69fdd1de2afa19a5ac5a4c87fbf21c5d87cc96d3fe30d58825c050f5a7d25f6d85d08efc')
prepare() {
cd "$pkgname"
git submodule init
- for name in nativefiledialog xdgpp libromfs capstone; do
+ for name in nativefiledialog xdgpp libromfs capstone pattern_language; do
git config submodule.lib/external/$name.url "$srcdir/$name"
done
- for name in yara/yara fmt curl; do
+ git config submodule.lib/external/yara/yara.url "$srcdir/yara"
+ for name in fmt curl; do
git config --remove-section submodule.lib/external/$name
done
git submodule update
@@ -66,11 +71,6 @@ prepare() {
git apply \
"$srcdir/0001-makepkg-Remove-external-stuff.patch" \
"$srcdir/0002-archlinux-compat-Remove-unused-mbedTLS-code-from-lib.patch"
-
- git -C lib/external/libromfs apply \
- "$srcdir/libromfs-0001-Fix-code-generation-for-clang.patch" || \
- git -C lib/external/libromfs apply -R --check \
- "$srcdir/libromfs-0001-Fix-code-generation-for-clang.patch"
}
build() {
@@ -82,7 +82,7 @@ build() {
-D CMAKE_INSTALL_PREFIX=/usr \
-D CMAKE_SKIP_RPATH=ON \
-D USE_SYSTEM_LLVM=ON \
- -D USE_SYSTEM_YARA=ON \
+ -D USE_SYSTEM_YARA=OFF \
-D USE_SYSTEM_FMT=ON \
-D USE_SYSTEM_CURL=ON \
-D USE_SYSTEM_NLOHMANN_JSON=ON \