summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJose Marino2018-09-13 11:37:07 -0600
committerJose Marino2018-09-13 12:57:34 -0600
commit2b09f1dc2d978dda6c9da1e0bc74d2cdc84b8264 (patch)
tree57c63a1a3dbcb81ee5bf0e4a328adc29dca78354 /PKGBUILD
parentcee5bd15c6f36e17bf4db159680ef20d600b6fb8 (diff)
downloadaur-2b09f1dc2d978dda6c9da1e0bc74d2cdc84b8264.tar.gz
don't accidentally delete tmp package
This line would delete folder 'node_modules/tmp' which contains package 'tmp'. Because of this, inboxer-1.1.5 would fail to start with: Error: Cannot find module 'tmp' I didn't find any other 'tmp' folders in 'node_modules' worth deleting. Thus, this line was not needed at all in the first place.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 2 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 537f98f3fbf2..dcdc2183116f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -23,8 +23,7 @@ sha256sums=('75041e1d60823ff2b2213a0ac129f694acbd939b5b1a14e4a6bf2044cea99162'
prepare() {
cd "$pkgname-$pkgver"
- # remove tracking from source
- # this eliminates dependencies insight and firstrun. Insight was causing trouble in version 1.1.5
+ # remove tracking (eliminates dependencies insight and firstrun)
patch -Np1 -i "${srcdir}/remove-tracking.patch"
sed -i '/"postinstall"/d' package.json
@@ -58,8 +57,7 @@ package() {
-or -name "nan" -prune -exec rm -r '{}' \; \
-or -name "obj.target" -prune -exec rm -r '{}' \; \
-or -name "script" -prune -exec rm -r '{}' \; \
- -or -name "test" -prune -exec rm -r '{}' \; \
- -or -name "tmp" -prune -exec rm -r '{}' \;
+ -or -name "test" -prune -exec rm -r '{}' \;
"$pkgname-$pkgver/node_modules/asar/bin/asar.js" pack "$pkgdir/tmp/" "$pkgdir/usr/lib/$pkgname/inboxer.asar"
rm -r "$pkgdir/tmp"