summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJose Marino2018-09-10 10:01:26 -0600
committerJose Marino2018-09-10 10:06:32 -0600
commit90bd78848f964938a7861e60bda9d1255e4ac9ee (patch)
tree5a0bea1fbad4e9057d25f9c52f0c17dfdf9356a4 /PKGBUILD
parent86f9ed74f13fd5973eddba67f485be9711518653 (diff)
downloadaur-90bd78848f964938a7861e60bda9d1255e4ac9ee.tar.gz
use older insight-0.8.4 version
The newer version of insight (0.10.1) breaks inboxer. It fails to start with the following error: Error: Cannot find module 'tmp'
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 11 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 68a49a43d770..694bbeb4c05f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=inboxer
pkgver=1.1.5
-pkgrel=1
+pkgrel=2
pkgdesc="Unofficial, free and open-source Google Inbox desktop app"
arch=(any)
url="https://denysdovhan.com/inboxer/"
@@ -13,13 +13,21 @@ makedepends=(npm)
options=(!strip)
source=($pkgname-$pkgver.tar.gz::https://github.com/denysdovhan/$pkgname/archive/v$pkgver.tar.gz
$pkgname.sh
- $pkgname.desktop)
+ $pkgname.desktop
+ use-insight-0.8.4.patch)
sha256sums=('75041e1d60823ff2b2213a0ac129f694acbd939b5b1a14e4a6bf2044cea99162'
'd8519d50a0becf00d2cd0809e4363087949fdc3d43c315ce26f87235e9ae6b27'
- '3048bb5c4d50269d27a46db7ff550f226881bd77ac6672573a0075b3b75ce2a0')
+ '3048bb5c4d50269d27a46db7ff550f226881bd77ac6672573a0075b3b75ce2a0'
+ '00e5c532adc0e1ab992075aa6fae2025cbc015d07847393a3cc7135f7f30eb6c')
build() {
cd $pkgname-$pkgver
+
+ # use older version of package insight (0.8.4)
+ # The newer version of insight (0.10.1) breaks inboxer. It fails to start with the following error:
+ # Error: Cannot find module 'tmp'
+ patch -p1 <../use-insight-0.8.4.patch
+
sed -i '/"postinstall"/d' package.json
npm install --production
}