summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorEmmanuel Gil Peyrot2015-09-19 12:16:12 +0100
committerEmmanuel Gil Peyrot2015-09-19 12:16:12 +0100
commit017558bfce6a6040028d557f6761d6d9fbf5d740 (patch)
tree260e48999f5ea08f26fadda40ea18e14885350d3 /PKGBUILD
parent2d29d5471761d747de0a3cfe2462ecef2a77e235 (diff)
downloadaur-017558bfce6a6040028d557f6761d6d9fbf5d740.tar.gz
Switch to the master branch now that clang 3.7 is in the repositories, and to python instead of python2.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 6 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 96b83260891c..8b921be69c79 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,19 +3,19 @@
_pkgbase=include-what-you-use
pkgname="$_pkgbase-git"
-pkgver=r510.4b74b71
+pkgver=r549.ca5bef8
pkgrel=1
pkgdesc="A tool for use with clang to analyze #includes in C and C++ source files"
url="http://code.google.com/p/include-what-you-use/"
license=('LLVM Release License')
arch=('i686' 'x86_64')
-depends=('clang>=3.6' 'clang<3.7')
-makedepends=('clang>=3.6' 'clang<3.7')
-optdepends=('python2')
+depends=('clang>=3.7' 'clang<3.8')
+makedepends=('clang>=3.7' 'clang<3.8')
+optdepends=('python: for the fix_includes.py script')
conflicts=("$_pkgbase")
-provides=("$_pkgbase=0.4")
+provides=("$_pkgbase=0.5")
-source=("$_pkgbase::git+https://github.com/include-what-you-use/include-what-you-use#branch=clang_3.6")
+source=("$_pkgbase::git+https://github.com/include-what-you-use/include-what-you-use")
sha1sums=('SKIP')
pkgver() {
@@ -26,7 +26,6 @@ pkgver() {
prepare() {
cd "$srcdir/$_pkgbase"
mkdir -p build
- sed -i "s|^#!/usr/bin/python$|#!/usr/bin/python2|" fix_includes.py
}
build() {