summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorhaawda2018-09-07 20:03:19 +0200
committerhaawda2018-09-07 20:03:19 +0200
commitd2739265aad4310bcae4f12d743b6f0feb14c39d (patch)
tree882472138ca8eb0fbd3d9a111ec3965e13ba50f9 /PKGBUILD
parent3287333066ef3b92a9209b8f565a92fcc384bc74 (diff)
downloadaur-d2739265aad4310bcae4f12d743b6f0feb14c39d.tar.gz
adopted and updated
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD39
1 files changed, 7 insertions, 32 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3090fea5f548..ccdd8ad8a569 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,49 +1,24 @@
-# $Id: PKGBUILD 310007 2017-11-15 14:11:34Z foutrelis $
-# Maintainer:
+# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
pkgname=indent
-pkgver=2.2.11
-pkgrel=4
+pkgver=2.2.12
+pkgrel=1
pkgdesc="C language source code formatting program"
arch=('x86_64')
url="https://www.gnu.org/software/indent/"
license=('GPL3')
depends=('glibc')
makedepends=('texi2html')
-source=(http://ftp.de.debian.org/debian/pool/main/i/indent/${pkgname}_${pkgver}.orig.tar.gz
- indent-2.2.11-segfault.patch
- indent-2.2.11-LC_ALL.patch
- indent-2.2.11-decimal_format.patch)
-sha1sums=('9b242528bbc4914464117c69ffae9df24d3fa4a7'
- '31a6dcd5edcac4decac81dbb52bc9415b8b148e4'
- '91b210b666de59ca44524288a4c1ebd213570daa'
- '2b7d5a725fe307ce81565f920a0a66b319b50c91')
-
-prepare() {
- cd "${srcdir}/${pkgname}-${pkgver}"
- patch -Np1 -i ../indent-2.2.11-segfault.patch
-
- # http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=205692
- patch -Np1 -i ../indent-2.2.11-LC_ALL.patch
-
- # https://lists.gnu.org/archive/html/bug-indent/2011-08/msg00000.html
- patch -Np1 -i ../indent-2.2.11-decimal_format.patch
-
- sed -i 's/-number/-number-sections/' doc/Makefile.in
-}
+source=("https://ftp-stud.hs-esslingen.de/pub/Mirrors/ftp.gnu.org/$pkgname/$pkgname-$pkgver.tar.xz")
+sha1sums=('eecb3d7e78516d846af70e7bc86aabac9b92399c')
build() {
- cd "${srcdir}/${pkgname}-${pkgver}"
+ cd ${pkgname}-${pkgver}
./configure --prefix=/usr
make
}
-check() {
- cd "${srcdir}/${pkgname}-${pkgver}/regression"
- make test
-}
-
package() {
- cd "${srcdir}/${pkgname}-${pkgver}"
+ cd ${pkgname}-${pkgver}
make DESTDIR="${pkgdir}" docdir=/usr/share/doc/indent install
}