summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorQue Quotion2019-08-17 01:14:36 +0900
committerQue Quotion2019-08-17 01:14:36 +0900
commit95e8ffb73d834c1fef2e9e2f9a940ccc0a137cb6 (patch)
tree5c63c676ef73266cba60d52cc79b39f49dffe215 /PKGBUILD
parentb5d4c89be80b5498690a68ea2adbb78a7ab71960 (diff)
downloadaur-indicator-sensors-git.tar.gz
Revamp dependencies
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 11 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b9000995d428..f5ca3ba01003 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Que Quotion <quequotion@bugmenot.com>
pkgname=indicator-sensors-git
-pkgver=0.8.r32.g6bfed17
+pkgver=0.9.r13.gab4487f
pkgrel=1
pkgdesc="Small application to provide hardware sensor readings using the AppIndicator framework (git version)"
arch=('i686' 'x86_64')
@@ -9,9 +9,11 @@ url="https://github.com/alexmurray/indicator-sensors"
license=('GPL3')
provides=('indicator-sensors')
conflicts=('indicator-sensors')
-depends=('dconf' 'libappindicator-gtk3' 'libatasmart' 'libnotify' 'libpeas' 'lm_sensors' 'udisks2')
-optdepends=('libxnvctrl: NVIDIA GPU support')
-makedepends=('gnome-common' 'intltool')
+depends=('libappindicator-gtk3' 'libnotify' 'libpeas' 'udisks2')
+optdepends=('libxnvctrl: NVIDIA GPU support'
+ 'libatasmart: ATA SMART support'
+ 'lm_sensors: Various sensor support')
+makedepends=('git' 'gnome-common' 'gobject-introspection' 'intltool')
install=indicator-sensors.install
source=("git+https://github.com/alexmurray/indicator-sensors"
'menu-cleanup.patch'
@@ -26,21 +28,22 @@ pkgver() {
}
prepare() {
- cd indicator-sensors
+ cd "indicator-sensors"
#Cleanup indicator menu (remove "about" and "quit")
patch -Np2 < ../menu-cleanup.patch
+
+ ./autogen.sh
}
build() {
- cd indicator-sensors
- sh ./autogen.sh
+ cd "indicator-sensors"
./configure --disable-schemas-compile --prefix=/usr
make
}
package() {
- cd indicator-sensors
+ cd "indicator-sensors"
make DESTDIR="$pkgdir" install
mkdir -p -m 750 "$pkgdir"/etc/polkit-1/rules.d/
install -m 644 ../is-udisks2.rules "$pkgdir"/etc/polkit-1/rules.d/