summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorValHue2015-06-26 11:10:35 +0200
committerValHue2015-06-26 11:10:35 +0200
commit7755c94d5355ed06437f4c234394fa5fb1fc0f46 (patch)
tree208b6aab164fb3a90554c2897bfb51144c2526c4 /PKGBUILD
parentb44d811f01caa2338c811d0b2fca2d3a9b3d5922 (diff)
downloadaur-7755c94d5355ed06437f4c234394fa5fb1fc0f46.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD37
1 files changed, 15 insertions, 22 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c7504311593b..ec3827367395 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,42 +6,35 @@ pkgver=12.10.1
pkgrel=5
pkgdesc='A unified sound menu'
arch=('i686' 'x86_64')
-url='https://launchpad.net/indicator-sound'
+url="https://launchpad.net/${pkgname}"
license=('GPL')
-groups=('pantheon' 'pantheon-unstable')
-depends=('ido' 'libdbusmenu-gtk3' 'libgee' 'libindicator-gtk3' 'libpulse'
- 'libnotify')
+depends=('ido' 'libdbusmenu-gtk3' 'libgee06' 'libindicator-gtk3' 'libpulse' 'libnotify')
makedepends=('intltool' 'vala')
-install='indicator-sound.install'
-source=("https://launchpad.net/indicator-sound/${pkgver%.*}/${pkgver}/+download/indicator-sound-${pkgver}.tar.gz")
-sha256sums=('d3ae4e8a9e2bac6f9098e617364aba1ddca15ee118d5aa89ae85d0a1f3371af6')
+install="${pkgname}.install"
+source=("${url}/${pkgver%.*}/${pkgver}/+download/${pkgname}-${pkgver}.tar.gz"
+ "http://pkgbuild.com/~bgyorgy/sources/${pkgname}-translations-20130310.tar.gz")
+sha256sums=('d3ae4e8a9e2bac6f9098e617364aba1ddca15ee118d5aa89ae85d0a1f3371af6'
+ '7830a7bf49b86f92558ad4bc1499db4e0c8680b0aa31d046262d8169b0bafcd2')
prepare() {
- cd indicator-sound-${pkgver}
+ cd ${pkgname}-${pkgver}
- sed 's/gee-1.0/gee-0.8/' -i configure.ac src/Makefile.{am,in}
- sed 's/rhythmbox/noise-player/g' -i data/com.canonical.indicator.sound.gschema.xml
-
- autoreconf -fi
+# Install updated language files
+ rename ${pkgname}- '' ../po/${pkgname}-*.po
+ mv -f -t po ../po/*
+ printf "%s\n" po/*.po | sed -e 's/po\///g' -e 's/\.po//g' >po/LINGUAS
}
build() {
- cd indicator-sound-${pkgver}
+ cd ${pkgname}-${pkgver}
export CFLAGS="$CFLAGS -Wno-deprecated-declarations"
-
- ./configure \
- --prefix='/usr' \
- --localstatedir='/var' \
- --libexecdir='/usr/lib/indicator-sound' \
- --sysconfdir='/etc' \
- --disable-schemas-compile \
- --disable-static
+ ./configure --prefix='/usr' --sysconfdir='/etc' --localstatedir='/var' --libexecdir="/usr/lib/${pkgname}" --disable-{schemas-compile,static}
make
}
package() {
- cd indicator-sound-${pkgver}
+ cd ${pkgname}-${pkgver}
make DESTDIR="${pkgdir}" install