summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorwillemw122015-06-08 12:13:00 +0200
committerwillemw122015-06-08 12:13:00 +0200
commit285dca166d24bbcf91f333af0b327c6821e73738 (patch)
treea493e46b2c3cf25388907d8ed82d498e70010c37 /PKGBUILD
downloadaur-285dca166d24bbcf91f333af0b327c6821e73738.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..98b7113f611d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: willemw <willemw12@gmail.com>
+
+_pkgname=indicator-weather
+pkgname=$_pkgname-bzr
+pkgver=r358
+pkgrel=3
+pkgdesc="Comprehensive weather notification system, implemented using the indicator applet API (Canonical Ayatana Project)"
+arch=('any')
+url="https://launchpad.net/weather-indicator"
+license=('GPL3')
+depends=('libappindicator-gtk3' 'libgweather' 'python2-pywapi' 'python2-pytz')
+optdepends=('python2-unidecode: for ASCII transliterations of Unicode text')
+makedepends=('bzr' 'python2-distutils-extra')
+provides=($_pkgname)
+conflicts=($_pkgname)
+install=$pkgname.install
+source=($pkgname::bzr+http://bazaar.launchpad.net/~weather-indicator-team/weather-indicator/rainy) # Series 2.0
+md5sums=('SKIP')
+
+pkgver() {
+ cd $pkgname
+ printf "r%s" "$(bzr revno)"
+}
+
+prepare() {
+ cd $pkgname
+ sed -i "s|share/common-licenses/GPL-3|share/licenses/common/GPL3/license.txt|" bin/indicator-weather
+}
+
+build() {
+ cd $pkgname
+ python2 setup.py build
+}
+
+package() {
+ cd $pkgname
+ python2 setup.py install --root="$pkgdir" --optimize=1
+ install -D -m644 AUTHORS "$pkgdir/usr/share/doc/indicator-weather/AUTHORS"
+}
+