summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRonny Lorenz2015-09-19 12:45:05 +0200
committerRonny Lorenz2015-09-19 12:45:05 +0200
commit818f017058950a4c959acb2e68905e7a29a510a7 (patch)
tree6f3e30a4b38557f8434d865dda6db06fe1760bf7 /PKGBUILD
downloadaur-818f017058950a4c959acb2e68905e7a29a510a7.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fe5264a11a76
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Ronny Lorenz <ronny at tbi dot univie dot ac dot at>
+
+pkgname=infernal
+pkgver=1.1.1
+pkgrel=2
+pkgdesc="Search DNA sequence databases for RNA structure and sequence similarities using covariance models (CMs)"
+arch=('x86_64' 'i686')
+license=('GPL3')
+url="http://infernal.janelia.org/"
+depends=('glibc')
+optdepends=()
+makedepends=()
+provides=()
+source=("http://selab.janelia.org/software/infernal/${pkgname}-${pkgver}.tar.gz")
+md5sums=( 'c5bff318f78c194a0d9b2a6bf1abb169')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ ./configure --prefix=/usr || return 1
+ make || return 1
+}
+
+#check(){
+# cd "${srcdir}/${pkgname}-${pkgver}"
+# make check
+#}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install || return 1
+}
+