summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJames P. Harvey2017-02-15 00:26:51 -0500
committerJames P. Harvey2017-02-15 00:26:51 -0500
commit64955d9e8286b4057ea619c0bfd2145a458bec07 (patch)
treefd7c12bde5be9021adf96fdf44700e169b7bad12 /PKGBUILD
parent01eb35ca8fd42a965c492bb4348f2d6f71d182e0 (diff)
downloadaur-64955d9e8286b4057ea619c0bfd2145a458bec07.tar.gz
Upstream's official release (3.3-19_g67c0807) still broken. Upstream's git's 3.3-22_g326b95a includes patch for recent GCC error, so removed fixMisleadingIndentation.patch, and temporarily using this until they officially release non-broken source again.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 5 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b6a3378fd2d2..71de82426ae2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,8 +7,8 @@ pkgname=infinipath-psm
_pkgname=psm
pkgver=3.3
_pkgver_subver=22
-_pkgver_commit=g4abbc60
-pkgrel=1
+_pkgver_commit=g326b95a
+pkgrel=2
pkgdesc='OpenFabrics Alliance Intel Performance Scaled Messaging library'
arch=('x86_64' 'i686')
url='https://www.openfabrics.org/index.php/overview.html'
@@ -16,18 +16,14 @@ license=('GPL2' 'custom:"Open Fabrics Alliance BSD"')
depends=('glibc' 'libutil-linux')
makedepends=('git')
# Latest more-official release at "https://www.openfabrics.org/downloads/${pkgname}/${pkgname}-${pkgver}-${_pkgver_subver}_${_pkgver_commit}_open.tar.gz" is broken
-source=("git+https://github.com/01org/${_pkgname}"
- "fixMisleadingIndentation.patch")
-md5sums=('SKIP'
- 'fc55d52e252217c264098d590663f95d')
+source=("git+https://github.com/01org/${_pkgname}")
+md5sums=('SKIP')
prepare() {
cd "${srcdir}/psm"
# Latest more-official release at "https://www.openfabrics.org/downloads/${pkgname}/${pkgname}-${pkgver}-${_pkgver_subver}_${_pkgver_commit}_open.tar.gz" is broken
# This isn't a -git AUR package, so grab the latest known and tested commit, as of the last updating of PKGBUILD
- git checkout 4abbc60
- # Newer GCC catches an unpatched error upstream
- git apply "${srcdir}/fixMisleadingIndentation.patch"
+ git checkout 326b95a
}
build() {