summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorYorick Peterse2022-09-12 23:11:25 +0200
committerYorick Peterse2022-09-12 23:11:25 +0200
commitb4381bf6622bbb10160241b46540f0b700a3ca36 (patch)
treeaf7d2574bdcb3eb1b1281a8b2b5701574f90f756 /PKGBUILD
parent508c6fdd6a43972329b18904ca8a950b7ed65b39 (diff)
downloadaur-b4381bf6622bbb10160241b46540f0b700a3ca36.tar.gz
Release v0.10.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 7 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 960f699fd006..739c47dc6905 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,25 @@
# Maintainer: Yorick Peterse <aur AT yorickpeterse DOT com>
pkgname=inko
-pkgver=0.9.0
+pkgver=0.10.0
pkgrel=1
pkgdesc="A statically-typed object-oriented language for writing concurrent programs"
+pkgdesc="A language for building concurrent software with confidence"
url="https://inko-lang.org"
license=(MPL2)
arch=(x86_64)
-depends=('ruby>=2.3.0' 'libffi>=3.2.0')
-makedepends=(coreutils 'rust>=1.34' make)
+depends=('libffi>=3.2.0')
+makedepends=('rust>=1.62' make)
provides=(inko)
conflicts=(inko-git)
options=(strip !docs !libtool !staticlibs)
source=("https://releases.inko-lang.org/${pkgver}.tar.gz")
-sha256sums=('311f6e675e6f7ca488a71022b62edbbc16946f907d7e1695f3f96747ece2051f')
+sha256sums=('d38e13532a71290386164246ac8cf7efb884131716dba6553b66a170dd3a2796')
build() {
- # Enable the libffi-system feature so the system libffy is used, instead of
+ # Enable the libffi-system feature so the system libffi is used, instead of
# compiling it from source.
- make build FEATURES='libinko/libffi-system' PREFIX='/usr'
+ make build FEATURES='libffi-system' PREFIX='/usr'
}
package() {