summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorhaawda2018-01-31 21:36:18 +0100
committerhaawda2018-01-31 21:36:18 +0100
commit2394c3608a61f920059a5e6a71301916ef73a7e6 (patch)
tree9fe9e5fe716b74484e743cdb9672fa31e06dab80 /PKGBUILD
parent2eb32baa1515ff23a51424631541604f0632bf2f (diff)
downloadaur-2394c3608a61f920059a5e6a71301916ef73a7e6.tar.gz
find imagemagick6
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 7 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index df91f911b3a8..2c5d934d6109 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=inkscape-092-git
pkgver=20180129.18207
-pkgrel=1
+pkgrel=2
pkgdesc="An Open Source vector graphics editor, using Scalable Vector Graphics (SVG) file format, from git branch 0.92.x"
url="https://gitlab.com/inkscape/inkscape"
arch=('i686' 'x86_64')
@@ -12,9 +12,10 @@ depends=('gtkspell' 'gtkmm' 'gc' 'poppler-glib' 'potrace' 'libxslt' 'gsl'
'python2' 'popt' 'libcdr' 'libvisio' 'popt' 'dbus-glib' 'gtkspell')
optdepends=('python2-numpy: some extensions'
'python2-lxml: some extensions and filters'
- 'uniconvertor: reading/writing to some proprietary formats'
- 'ruby: for simplepath extension')
+ 'ruby: for simplepath extension'
+ 'imagemagick6: for some file conversions')
makedepends=('boost' 'intltool' 'git' 'gettext' 'pango' 'fontconfig' 'python' 'cmake')
+ 'uniconvertor: reading/writing to some proprietary formats'
provides=('inkscape')
conflicts=('inkscape')
options=('!libtool' '!makeflags')
@@ -43,14 +44,13 @@ build() {
cd "$_gitname"
[[ -d build ]] || mkdir build
cd build
-
+ export PKG_CONFIG_PATH="/usr/lib/imagemagick6/pkgconfig"
cmake .. \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_BUILD_TYPE=RELEASE \
-DWITH_GNOME_VFS=OFF \
- -DWITH_DBUS=ON \
- -DWITH_IMAGE_MAGICK=OFF
-
+ -DWITH_DBUS=ON
+
sed -i 's|"python"|"python2"|g' ../share/filters/CMakeLists.txt
make
}