summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorhaawda2018-11-17 16:33:13 +0100
committerhaawda2018-11-17 16:33:13 +0100
commitae247ef57f605c43f4c94ea7bec391c0497a9adf (patch)
treed755fced5317a8ac8e9f2b839ebb0343653d8b88 /PKGBUILD
parent5eb8e1e4c09b3cac0e441e2978361f7fbb5e56fe (diff)
downloadaur-ae247ef57f605c43f4c94ea7bec391c0497a9adf.tar.gz
new pkgver function, epoch required
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 80b3f9817ebc..3eef1460a29f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,8 @@
# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
pkgname=inkscape-092-git
-pkgver=20181112.18312
+epoch=1
+pkgver=0.92.3.r84.g4e014550a5
pkgrel=1
pkgdesc="An Open Source vector graphics editor, using Scalable Vector Graphics (SVG) file format, from git branch 0.92.x"
url="https://gitlab.com/inkscape/inkscape"
@@ -26,7 +27,7 @@ _gitname="inkscape.git"
pkgver() {
cd "$_gitname"
- printf %s.%s $(git log -1 --format="%cd" --date=short|tr -d -) $(git rev-list --count HEAD)
+ git describe --long --tags | sed 's/^INKSCAPE_//;s/\([^-]*-g\)/r\1/;s/[-_]/./g;s/\(.*\)/\L\1/'
}
prepare() {
@@ -34,7 +35,6 @@ prepare() {
find share -type f -name "*.py" -exec \
sed -i '1s|/usr/bin/env python\>|/usr/bin/env python2|g' {} \;
sed -i 's|"python" },|"python2" },|g' src/extension/implementation/script.cpp
- sed -i -e 's|GBool|bool|g' -e 's|gTrue|true|g' -e 's|gFalse|false|g' src/extension/internal/pdfinput/pdf-parser.{h,cpp}
}
build() {