summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMarius Knaust2018-06-21 15:31:14 +0200
committerMarius Knaust2018-06-21 15:31:14 +0200
commit1827636b4d8439209b59caca57d0744239ce625a (patch)
tree957066f4faa14e502dcd1923916c3c9670f39511 /PKGBUILD
downloadaur-1827636b4d8439209b59caca57d0744239ce625a.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b8307a79febe
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Marius Knaust <marius.knaust@gmail.com>
+
+_name=inkscape-applytransforms
+pkgname=$_name-git
+pkgver=r20.1d86e12
+pkgrel=1
+pkgdesc="An Inkscape extension which removes all matrix transforms by applying them recursively to shapes"
+arch=("any")
+url="https://github.com/Klowner/$_name"
+license=("GPL2")
+depends=("inkscape" "python2-lxml")
+makedepends=("git")
+provides=("_name")
+conflicts=("_name")
+source=("git+https://github.com/Klowner/$_name.git")
+md5sums=("SKIP")
+
+pkgver()
+{
+ cd "$_name"
+
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package()
+{
+ cd "$srcdir/$_name"
+
+ install -m755 -Dt "$pkgdir/usr/share/inkscape/extensions" applytransform.py
+ install -m644 -Dt "$pkgdir/usr/share/inkscape/extensions" applytransform.inx
+}