summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorhaawda2017-11-22 22:22:35 +0100
committerhaawda2017-11-22 22:22:35 +0100
commit776ffd13839185fcf8cf1c9b552679f341287195 (patch)
tree523f66835aede45fafbb1b7b6b38b87a2b38df6d /PKGBUILD
parentfbecd0a617c713d044073b4f7580b2dfa95505f6 (diff)
downloadaur-776ffd13839185fcf8cf1c9b552679f341287195.tar.gz
fix python stuff
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD5
1 files changed, 4 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ccbf39048571..5841c8e33681 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=inkscape-git
pkgver=20171122.19779
-pkgrel=1
+pkgrel=2
pkgdesc="An Open Source vector graphics editor, using SVG file format, from git master"
url="https://launchpad.net/inkscape"
arch=('i686' 'x86_64')
@@ -35,6 +35,9 @@ prepare() {
find share -type f -name "*.py" -exec \
sed -i '1s|/usr/bin/env python\>|/usr/bin/env python2|g' {} \;
sed -i '1s|/usr/bin/env python3\>|/usr/bin/env python2|g' CMakeScripts/cmake_consistency_check.py
+ sed -i 's|/usr/bin/env python\>|/usr/bin/env python2|g' share/*/{test/,}*.py
+ sed -i 's|"python" },|"python2" },|g' src/extension/implementation/script.cpp
+ sed -i 's|"python"|"python2"|g' src/main.cpp
}
build() {