summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorbartus2018-11-18 14:02:25 +0100
committerbartus2018-11-18 14:02:25 +0100
commite2d676b6cf9824e901939d929cb14f1ab0ee1d7c (patch)
tree6f2d5115b6f31d8a2696c64b1fe554d1d016802e /PKGBUILD
parentd1f23e4807f86f4923dbac45586672290d4fb2cb (diff)
downloadaur-e2d676b6cf9824e901939d929cb14f1ab0ee1d7c.tar.gz
replace pkgver with regural version string
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 500892027da2..ac157d4c93d6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,9 @@
# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
pkgname=inkscape-git
-pkgver=20181113.20941
+pkgver=0.92+devel.r3569.ge1eae41f45
pkgrel=1
+epoch=1
pkgdesc="An Open Source vector graphics editor, using SVG file format, from git master"
url="https://launchpad.net/inkscape"
arch=('i686' 'x86_64')
@@ -26,7 +27,7 @@ _gitname="inkscape.git"
pkgver() {
cd "$_gitname"
- printf %s.%s $(git log -1 --format="%cd" --date=short|tr -d -) $(git rev-list --count HEAD)
+ printf %s.%s+devel.r%s.g%s $(grep -oP -e "INKSCAPE_VERSION_(MAJOR|MINOR) +\K[0-9]+" CMakeLists.txt) $(git rev-list $(git describe --tag --abbrev=0)..HEAD --count) $(git log --pretty=format:'%h' -n 1)
}
prepare() {