summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRod Kay2021-06-07 01:28:18 +1000
committerRod Kay2021-06-07 01:28:18 +1000
commit1058e4ca1f79a2d10d16960989103e933a06e7b4 (patch)
tree8437f8aed275931439671811e371e1ddcfc63c2b /PKGBUILD
downloadaur-1058e4ca1f79a2d10d16960989103e933a06e7b4.tar.gz
Initial package.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c53618828e6d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Rod Kay <charlie5 on #ada at irc.libera.chat>
+
+pkgname=inotify-ada
+pkgver=20210606
+pkgrel=1
+
+pkgdesc='An Ada 2012 library to monitor filesystem events using the Linux inotify API.'
+url='https://github.com/onox/inotify-ada'
+arch=('i686' 'x86_64')
+license=('Apache License 2.0')
+
+depends=('gcc-ada' 'alire')
+makedepends=('gprbuild')
+
+source=("https://github.com/onox/inotify-ada/archive/refs/heads/master.zip")
+sha1sums=("a07c29269552ba496681ff7bd897ca38ecd829ba")
+
+
+build()
+{
+ cd $srcdir/$pkgname-master
+ make build
+}
+
+
+package()
+{
+ cd $srcdir/$pkgname-master
+
+ mkdir -p $pkgdir/usr/bin
+ make PREFIX=$pkgdir/usr install
+
+ gprinstall -P inotify.gpr -p --prefix=$pkgdir/usr
+}