summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorbegin-theadventure2023-08-19 20:38:47 +0200
committerbegin-theadventure2023-08-19 20:38:47 +0200
commit538038cb2fa7956258062624b9fb985153ed7f3a (patch)
treeb94bf8d29e3154b99f8406a21f9e00419685a044 /PKGBUILD
parent624261944035e39cae6975a3d23fdf692bd0bcb5 (diff)
downloadaur-538038cb2fa7956258062624b9fb985153ed7f3a.tar.gz
Adopt Package, 2.0.4
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 13 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c75b8cc3a4fd..a2ce31cda46d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,24 @@
-# Maintainer: Caltlgin Stsodaat <contact@fossdaily.xyz>
+# Maintainer: begin-theadventure <begin-thecontact.ncncb at dralias dot com>
+# Contributor: Caltlgin Stsodaat <contact@fossdaily.xyz>
-pkgname='inspektor'
-pkgver=1.0.32
-pkgrel=2
+pkgname=inspektor
+pkgver=2.0.4
+pkgrel=1
pkgdesc='View metadata information on files'
arch=('any')
url='https://github.com/hezral/inspektor'
license=('GPL3')
-depends=('attr' 'gtk3' 'perl-image-exiftool' 'python')
-makedepends=('python-setuptools')
-source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz")
-sha256sums=('41057ef4efb61a24cfb6cf70a2e45381542774635f5080803dba5ba0b5429444')
+depends=('attr' 'granite' 'gtk3' 'perl-image-exiftool' 'python-opencv')
+makedepends=('git' 'meson')
+source=("git+$url.git#tag=$pkgver")
+sha256sums=('SKIP')
build() {
- cd "${pkgname}-${pkgver}"
- python setup.py build
+ arch-meson $pkgname build
+ meson compile -C build
}
package() {
- cd "${pkgname}-${pkgver}"
- python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
- install -Dvm644 'README.md' -t "${pkgdir}/usr/share/doc/${pkgname}"
+ DESTDIR="$pkgdir" meson install -C build
+ ln -fs /usr/bin/com.github.hezral.$pkgname "$pkgdir/usr/bin/$pkgname"
}
-
-# vim: ts=2 sw=2 et: