summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSébastien Luttringer2015-06-18 03:30:08 +0200
committerSébastien Luttringer2015-06-18 03:30:08 +0200
commitbde729ba3750079309e4a09ef2a374e54948b6d0 (patch)
tree9c5dfd07922235ff5d22413a4f1011eca616c220 /PKGBUILD
downloadaur-installsystems.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0aa761f2ec69
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Sébastien "Seblu" Luttringer
+
+pkgname=installsystems
+pkgver=9
+pkgrel=1
+pkgdesc='Easy Installation Framework'
+arch=('any')
+license=('GPL2')
+url='https://github.com/seblu/installsystems'
+groups=('base')
+makedepends=("git")
+depends=('python2' 'python2-psutil' 'python2-progressbar' 'python2-jinja')
+optdepends=('python2-paramiko: support ssh repositories')
+source=("git+https://github.com/seblu/installsystems.git#tag=v$pkgver")
+md5sums=('SKIP')
+
+build() {
+ cd $pkgname
+ python2 setup.py build
+}
+
+package() {
+ cd $pkgname
+ python2 setup.py install --root="$pkgdir" --optimize=1
+ # fix bash completion path
+ cd "$pkgdir"
+ install -dm755 usr/share/bash-completion
+ mv etc/bash_completion.d usr/share/bash-completion/completions
+}
+
+# vim:set ts=2 sw=2 et: